Ask Your Question
0

Text selection: how to mark quote as Arabic language?

asked 2019-07-20 17:51:49 +0200

leidner gravatar image

When writing an English-language document, which contains an Arabic name, LibreOffice Writer does not let me mark a text span and declare the selection to be in the Arabic language for purposes of proper rendering, spell-checking etc.

The Arabic language is missing entirely from the list of languages, i.e. there is no entry “Arabic“ between "Apatani" and "Aragonese" under Tools → Language → For Selection → More… → Language

Version info: LibreOffice Version: 6.2.5.2 Ubuntu Linux AMD64

edit retag flag offensive close merge delete

Comments

an Arabic name

Is it written in Arabic?

gabix gravatar imagegabix ( 2019-07-20 17:54:44 +0200 )edit

If you are missing "Arabic" you may need to tick Tools -> Options -> Language Settings -> Languages -> Category: Default Languages for Documents -> Option: Complex text layout and you'll get more than 25 different Arabic language versions.

Opaque gravatar imageOpaque ( 2019-07-20 19:17:07 +0200 )edit

Note the document is written in English, so I don't want to set the document language or default language for all future documents to anything other than English. The name is written in Arabic (and "bidi", from right to left).

leidner gravatar imageleidner ( 2019-07-20 20:31:35 +0200 )edit

Follow Opaque's advise. It won't change your defaults.

gabix gravatar imagegabix ( 2019-07-20 21:34:34 +0200 )edit

I agree that just reading the option from my comment, you may get the idea, that it changes any default. In that sense, the path sounds a bit misleading. But give the dialog a try and you will recognize that it is about "supporting additional languages" (watch the plural) havin a complex text layout, which is just impelemted as a separated option to avoid all the related overhead for users not dealing with such languages. Of course it is your choice, but if you don't make that setting, you won't have the functionality to change your selection to Arabic.

Opaque gravatar imageOpaque ( 2019-07-21 12:50:28 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-07-21 15:11:46 +0200

Opaque gravatar image

updated 2019-07-21 15:13:17 +0200

Hello,

according to my first comment: If you are missing "Arabic" to declare your selection containing text in Arabic language, you need to tick Tools -> Options -> Language Settings -> Languages -> Category: Default Languages for Documents -> Option: Complex text layout and you'll get more than 25 different Arabic language versions. This adds additional language options within the related dialog and does not change any default settings.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-20 17:51:49 +0200

Seen: 26 times

Last updated: Jul 21