Ask Your Question
2

Using AutoCorrect to Format Characters in a Word [closed]

asked 2013-07-16 03:32:41 +0200

Lance gravatar image

updated 2015-11-11 05:36:26 +0200

Alex Kemp gravatar image

When typing a some certain words I would like the characters of the words to automatically be formatted. For example, when I type LAeq I would like it to be correctly formatted as LAeq.

The solution I've found is to format the word, highlight the word, select AutoCorrect Options from the Tools menu, and type the word that I want to be the replacee. Also, I need to make sure that the Text Only check box remains unchecked.

I've come across two bugs that seem to relate to my problem, but they have been marked as fixed. https ://bugs.freedesktop.org/show_bug.cgi?id=38242 and https ://bugs.freedesktop.org/show_bug.cgi?id=48971

I'm using LibreOffice Version 4.0.4.2

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-11 05:36:36.717893

3 Answers

Sort by » oldest newest most voted
0

answered 2013-10-12 15:37:03 +0200

manj_k gravatar image

The related bug is
Bug 67697 - Autocorrect entries with formatting cannot be added
Status: RESOLVED FIXED
target: 4.1.3/4.0.6.

I have tested AutoCorrect Options... → Replace successfully
with LibreOffice 4.0.6.1 (RC1), and LibreOffice 4.1.3.1 (RC1).

edit flag offensive delete link more

Comments

Tested (e.g.) with "LAeq" → LAeq (see question).

manj_k gravatar imagemanj_k ( 2013-11-16 00:03:23 +0200 )edit
1

answered 2013-07-17 11:05:14 +0200

mahfiaz gravatar image

What you are after is AutoText. It works like this: type fn and press F3, it replaces the text with predefined snippet. You can create your own entries.

Read more: https://help.libreoffice.org/Writer/Using_AutoText

edit flag offensive delete link more

Comments

This is correct. I just wish AutoText was easier to use. The shortcut (e.g., "fn") in particular seems difficult to set as required. I suppose the entire dialog UI will be addressed at some point because it is not the most straightforward facility.

oweng gravatar imageoweng ( 2013-07-17 12:02:39 +0200 )edit

I'm not sure Autotext is what I'm after. While it can accomplish the task, it is adding extra step to the process. If you have access to Microsoft Word 2000 or later you can see the feature I'm after. Type LAeq, put the Aeq in subscript. Select the formated text and copy it to clip board then select AutoCorrect from the tools menu. The replacee should be LAeq, and the replacement text paste in the text from the clip board and select formated text. Now try type LAeq in your document.

Lance gravatar imageLance ( 2013-07-18 07:23:01 +0200 )edit

@Lance - Then it would be autoreplace with formatting, which LO doesn't currently do. You are more than welcome to file a bug report about it, remember to mark it as enchancement request and post a link back here.

mahfiaz gravatar imagemahfiaz ( 2013-07-18 10:07:04 +0200 )edit

Thanks. Just having a bit more of a look at https://help.libreoffice.org/Common/Replace and it says, under the Replacement table section, "You can use the AutoCorrect feature to apply a specific character format to a word or abbreviation. Select the formatted text in your document, open this dialog, clear the Text only box, and then enter the text that you want to replace in the Replace box.". The Text only box seems to do nothing for me, so perhaps its a bug and not a feature request?

Lance gravatar imageLance ( 2013-07-18 12:03:19 +0200 )edit

You are right. Help suggest it should work, but I couldn't get it to work either, tried quite many times and ways, nothing. So yes, it's a bug then.

mahfiaz gravatar imagemahfiaz ( 2013-07-18 12:55:12 +0200 )edit
1

answered 2013-08-24 06:36:11 +0200

Anatta gravatar image

Bug 38242 and 48971 is not related to this. The settings for that is at a different place (Tools - AutoCorrect Options - Localized Options tab).

I've tested it and confirm this bug. Consider submitting a bug report at https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice Since the help file says that should work, it looks like a regression. So, include [REGRESSION] in the title. That should get more attention of the coders.

edit flag offensive delete link more

Comments

1

fdo#64699 has been marked as a duplicate of fdo#67697.

manj_k gravatar imagemanj_k ( 2013-10-12 15:39:23 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-07-16 03:32:41 +0200

Seen: 777 times

Last updated: Oct 12 '13