Ask Your Question
0

how do i remove recent files from panel icon?

asked 2019-08-16 21:22:06 +0200

mintlipshitz gravatar image

i have the calc and writer icons pinned to the panel (using linux mint) when i right click on one of them i can view recent files how can i delete any or all of them?

edit retag flag offensive close merge delete

Comments

Not sure what you mean by "panel". Have you tried double-clicking on the LibreOffice icon to open it? That should give you a window with thumbnails of your recent documents. If you hover your mouse over any of the thumbnails, a little "X" will appear in the upper-right-hand corner of that thumbnail. Click on the X to delete the thumbnail, and the document will disappear from your list of recent documents.

ve3oat gravatar imageve3oat ( 2019-08-16 21:57:07 +0200 )edit

When I add Calc and Writer to the panel on Mint they do not show any recently used files when right clicking on the icon (Using LO 6.3.0.4 on Mint 19). Which desktop environment are you using - Cinnamon?

Opaque gravatar imageOpaque ( 2019-08-16 23:26:01 +0200 )edit

mint with cinnamon v4.0.10. when i right click on the calc panel icon i see preferences, recent, new spreadsheet and unpin from panel options. then when i click on recent i can see the recently opened files. these are the ones i want to remove. there is no clear option here

mintlipshitz gravatar imagemintlipshitz ( 2019-08-16 23:35:28 +0200 )edit

well the search is over and i found out what the deal is. seems the recent files list on the calc panel icon (and writer, too) is directly related to the recent files list on the start menu. when i clear the start menu items it also clears the panel icons recent files list in its entirety. thanks for all the input on this one. hope others can learn from this.

mintlipshitz gravatar imagemintlipshitz ( 2019-08-17 17:20:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-08-17 12:25:14 +0200

Opaque gravatar image

Hello,

though this isn't a LibreOffice specific question here is a probable answer: Please check file .local/share/recently-used.xbel in your home directory. This XML file contains your recently used file as bookmark. To remove a specific entry you need to remove everything between <bookmark href= .......... > and <\bookmark>.

Hope that helps.

If the answer is correct or helped you to fix your problem, please click the check mark (✔) next to the answer.

edit flag offensive delete link more

Comments

this did not work to remove the entry from the panel icon's recent file list, though it may have removed it from the start menu recent file list, i will never know because i did not check to see if it was there before i deleted the entry in the recently-used.xbel file. thanks for the info

mintlipshitz gravatar imagemintlipshitz ( 2019-08-17 16:30:06 +0200 )edit

I have tested before posting anbd this worked for me.

Opaque gravatar imageOpaque ( 2019-08-18 17:10:56 +0200 )edit
0

answered 2019-08-16 22:43:24 +0200

mintlipshitz gravatar image

since you don't know what the panel in linux mint is i will assume that you do not know about this OS. the panel in linux mint is the equivalent to the task bar in windows. also, deleting the recent documents where you suggested is different from what i am trying to do.

edit flag offensive delete link more

Comments

Understood (I use Ubuntu and Mate). I would delete my suggestion but the time has regretibly expired.

ve3oat gravatar imageve3oat ( 2019-08-17 01:07:04 +0200 )edit

appreciate the attempt, still drudging on

mintlipshitz gravatar imagemintlipshitz ( 2019-08-17 07:44:00 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-16 21:22:06 +0200

Seen: 37 times

Last updated: Aug 17