Ask Your Question
0

"After" spacing in Footnote disappears after save as Word2003 / Load

asked 2019-08-25 11:01:04 +0200

ZX Spectrum gravatar image

updated 2019-08-25 11:07:26 +0200

Hello!

I trying to set a proper spacing between footnote number and footnote text. I use the Tools -> Footnotes and Endnotes -> After, and put there some spaces or another characters whatever.

All looks great and all works while using ODT file format. But if I save my doc as Word 97-2003 and reload it, spacing in After section and in text completely disappears. Format of Footnote paragraph, i.e. indents & so saved pretty well for DOC - the only problem is space between foortnote number and footnote itself.

Yes, I know about "work-in-ODT-only" truestory, but may be someone can help me with proper adjustment of Writer+DOC?

edit retag flag offensive close merge delete

Comments

That seems to be an export filter bug. Please, fill a bug report providing a sample file and a detailed step by step procedure to reproduce the problem.

RGB-es gravatar imageRGB-es ( 2019-08-25 11:08:07 +0200 )edit

A note: the sample file should be an ODT, where it's OK; and it would be nice to also attach a side-by-side screenshot with marked difference between ODT and DOC to the bug...

By the way, you didn't tell your LO version: it's always good to check if the problem exists in the newest version before submitting a bug.

And btw, it seems that Word (and thus, likely its formats) doesn't have a feature for "text after footnote number", so it would be impossible to save that information in DOC:

image description

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-25 12:09:28 +0200 )edit

Sadly. Well, it seems like remains to use a hanging indent. Thank you for explanation.

ZX Spectrum gravatar imageZX Spectrum ( 2019-08-25 14:32:42 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-08-25 12:31:39 +0200

The proper way to define spacing between footnote number and its text is modifying indents of the paragraph style used for footnotes. Increasing the Before text (positive) and First line (negative, hanging indent) increases the spacing (because the footnote number is output at the "first line" indent position, and the rest is output starting at "before text" indent position). This setting is correctly saved after saving to DOC.

But that doesn't allow to make first line of the footnote text to be indented differently from the rest lines of the footnote text.

edit flag offensive delete link more

Comments

Yep, its look good, and I already use "hanging indent" like a last resort. But in DOC I found impossible to format a "normal" paragraph in footnote with clearly notable and similar indent.

Here the user with similar task: https://ask.libreoffice.org/en/questi... - but here solution was found for ODT in Tools -> Footnotes and Endnotes -> After

ZX Spectrum gravatar imageZX Spectrum ( 2019-08-25 14:30:15 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-25 11:01:04 +0200

Seen: 25 times

Last updated: Aug 25