Ask Your Question
0

How do I confirm reloading of external sources in Calc

asked 2019-10-17 16:02:45 +0100

goodoldac gravatar image

updated 2019-10-18 10:47:20 +0100

I have created two separate files in Calc. One is for my accounts and the other for general finances, which are both in the same folder called Calc. In the general finances file, I want to show the current balance in the accounts file. I have tried to do this firstly by selecting the cell in finances, then clicking on the = sign at the top, then selecting the cell containing the balance in the accounts file, then returning to finances and clicking the tick sign. However, when I do this it produces “Error 540” which tells me that “External content is disabled” etc. I have tried to find out how to enable external content without success. Can someone help please. I am using Libre Office version: 6.3.2.2 (x64) on a Dell desktop computer with a Windows 10 operating system.

edit retag flag offensive close merge delete

Comments

Is that when reloading the document, or when creating such formula? If the latter, we had one such report but could not reproduce. It would need much more detailed information (LibreOffice version, operating system, location of files, formula used) you can provide it editing your question (please do not use the Answer field for this). If it's instead when reloading the file, there's an Info Bar at the top of the document view to accept external resources.

erAck gravatar imageerAck ( 2019-10-17 17:56:46 +0100 )edit

From your amended description it follows you had both documents open. I can't reproduce on Linux, maybe someone on Windows can.

What are your settings under Tools -> Options -> LibreOffice -> Security

  • Options: Security Options: Block any links from documents not among the trusted locations (see Macro Security)
    • checked or unchecked?
  • Macro Security: Security Level
    • Very high, High, Medium or Low?
  • Macro Security: Trusted Sources, Trusted File Locations
    • any location added?
erAck gravatar imageerAck ( 2019-10-18 16:17:49 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-19 10:09:15 +0100

goodoldac gravatar image

Taking your advice, I have gone to Macro Security and changed the setting from high to low (this is not a problem as Im the only user of theCalcfolder). I have then entered the folders location in Trusted Sources and the problem is solved. My grateful thanks to erAck for your help.

edit flag offensive delete link more

Comments

Changing from High to Low shouldn't be necessary though, adding the folder to Trusted Sources should be sufficient. Also, you being the only user somewhat misses the point, for example if you download a document or receive one via mail attachment opening that can expose you to macros or external references.

erAck gravatar imageerAck ( 2019-10-20 19:02:00 +0100 )edit

I have now reset the Macro Security setting back to High and the function still works ok. I appreciate what youre saying about downloaded documents and emails and that this would be an important security issue for a lot of users. However, my financial files on the computer have always been restricted to it and to date Ive never downloaded anything from the internet into them.

goodoldac gravatar imagegoodoldac ( 2019-10-21 10:10:14 +0100 )edit

Btw, maybe you should use real apostrophe ' and not ` backticks ... ;-)

erAck gravatar imageerAck ( 2019-10-21 14:13:57 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-17 16:02:45 +0100

Seen: 60 times

Last updated: Oct 19