Ask Your Question
0

indent on first line of each page

asked 2019-10-18 02:05:07 +0100

harpwriter gravatar image

updated 2019-10-18 14:14:49 +0100

This happens when I re-save an .odt to .docx to upload to amazon/kdp.

The first line of many pages (ie, at the top of a new page) is indented about 3 spaces.

In other places, there's an break in a sentence such that there's a gap (several empty lines) at the bottom of one page, and then one word from the sentence is on the next page.

Any idea what's causing this and more importantly is there a way to fix it without going through page by page hitting back space to correct each instance?

Thank you.

edit retag flag offensive close merge delete

Comments

From your last sentence, you suggest that stray "real" spaces have been added by the conversions. Do you confirm this is the case and not a formatting artifact (no real spaces but an error in text formatting)?

In the top-of-the page case, have you a "non-breaking space" as first character of the line followed by one or several ordinary spaces? More generally, are you sure all your spaces (apart from very specific needs) are simple spaces, typed with the space bar, and not special spaces obtained from the space bar + modifiers (Shift, Alt or Ctrl)? Mixing ordinary and special spaces causes "funny" but predictable results with justification.

These effects are present in both versions of the text (.odt and .doc(x)) but may be revealed by the difference in page layout.

ajlittoz gravatar imageajlittoz ( 2019-10-18 08:07:48 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-18 14:12:57 +0100

harpwriter gravatar image

Thank you ajittoz. These are formatting issues that arise when converting from .odt to .docx. Sometimes it's far worse, causing a page break every paragraph or so such that most of a page ends up blank with only one paragraph at the top.

What I found last night is that the problem is page styles. During the conversion, my page styles all became converted 1, converted 2....converted 267. I found two solutions.

  1. I went back in and edited the DEFAULT page style in the organizer tab to be followed by DEFAULT. I still had to go through and fix the first page of each chapter, which I did by inserting the cursor in front of the word chapter, backspace so that the chapter heading went to the previous page and became default text, and then once again turned it to HEADING 1.

    [HEADING 1 was already defined to insert a page break before the paragraph, and I re-set the page break to DEFAULT.]

If there was an easier way to do that, I'd still like to know, but it got rid of those unwanted spaces and awkward empty spaces on the pages.

  1. I gave up on KDP and used draft2digital. Although I originally intended to say that tongue in cheek, the fact is, the same document that continued to have issues at one worked beautifully and absolutely perfectly at the other, on the first try.
edit flag offensive delete link more

Comments

I wonder if this is an "answer" or just a comment, in which case it should have been entered with "add comment".

The problem with page styles comes from the fact that Word has no notion of page style and every occurrence must be converted to some equivalent set of other primitives. Hence, the "converted-n".

Easier way …

It depends on the degree of "styleness" of your document and the presence (frequency) of direct formatting. Usually mixing styles and direct formatting leads into this sort of trouble.

KDP? draft2digital? What these applications? How do they relate to LibreOffice?

ajlittoz gravatar imageajlittoz ( 2019-10-18 18:15:08 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-18 02:05:07 +0100

Seen: 42 times

Last updated: Oct 18