We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

Can't use personas in LO [closed]

asked 2013-08-13 17:56:54 +0200

marinecomm gravatar image

updated 2015-11-05 05:58:03 +0200

Alex Kemp gravatar image

I go to Tools -> Options -> Personalization. I check 'Own Theme', then click on 'Select Theme'. I found the theme I wanted, copied and pasted the URL in the "Select Theme' window and when I click 'OK". LibreOffice crashes.

I even tried looking in this folder: /home/jason/.mozilla/firefox/3yvxv88p.default/lwtheme to copy and paste the images into the LibreOffice gallery, but the images for my current theme are not there. I have images from a previous theme which are also in the LibreOffice gallery. I can't seem to get personas to work in LibreOffice Any thoughts or suggestions? I am running Xubuntu 12.04 64-bit.

I installed LibreOffice 4.1 through the synaptic package manager.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-05 05:58:22.364805


Please edit your question and report how did you install your LibreOffice, from PPA or packages from libreoffice.org. Unless anyone reports "personas" working well with LO 4.1.04 in Xubuntu 12.04 64bit, this might be a bug. Check this Q&A and follow the following links to find/report a bug https://www.libreoffice.org/get-help/bug/, https://bugs.launchpad.net/~libreoffice

carnendil gravatar imagecarnendil ( 2013-08-13 19:19:59 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2013-08-13 22:06:55 +0200

petermau gravatar image

updated 2013-08-13 23:31:26 +0200

carnendil gravatar image

There appears to be a bug fdo#59230 which affects some Linux 4.1 systems.

The description of this bug also shows you how you can bypass the Tools > Options > Personalization screen to manually install a LibreOffice personas. This requires you to manually update the registrymodifications.xcu file if you are confident in doing that.

I see you have already reported this as a bug. Peter

edit flag offensive delete link more


You can also follow instructions given here, and save the image files with the same names given in registrymodifications.xcu, so there's no need to modify this file.

carnendil gravatar imagecarnendil ( 2013-08-13 23:37:07 +0200 )edit

The technique camendil describes works fine to change a personas, and I use it on my Ubuntu systems with LibO 4.10.4. However, if LibO crashes or fails to create an initial personas, the personas folder will not have been created and there will be no existing entry in the registrymodifications.xcu file. If you upgrade from 4.0 with personas to 4.1 there will already be an entry in the .xcu file.

petermau gravatar imagepetermau ( 2013-08-14 10:28:43 +0200 )edit

Using the version, this code seems to be relevant. Paste it in your registrymodifications.xcu file after modifying the HEADER and FOOTER names (they need to be in ~/.config/libreoffice/4/user/gallery/personas/) This of course, only applies in the situation petermau described above (no previous installation)

snipertyler gravatar imagesnipertyler ( 2013-08-24 02:07:25 +0200 )edit

@petermau please let us know if the code provided by @snipertyler solves the problem.

carnendil gravatar imagecarnendil ( 2013-08-26 17:25:28 +0200 )edit

Question Tools

1 follower


Asked: 2013-08-13 17:56:54 +0200

Seen: 682 times

Last updated: Aug 13 '13