Ask Your Question
0

deactivate emoji style - reactivate text style

asked 2019-11-15 21:51:11 +0100

marcusman gravatar image

Hello,

I'm having a problem with a symbol that I want to render with the Liberation Sans Font. Previously, the symbol was rendered as usual, like all the other letters ("text style"). Currently, the symbol is being rendered as a big fat comic-like emoji ("emoji style"). I want to render that symbol in the old style ("text style"). How can I achieve this, in particular using LibreOffice Writer.

I want this: ⚔
That's what I get: ⚔️

More about that problem here: http://xahlee.info/comp/text_vs_emoji...
And here: https://forum.lazarus.freepascal.org/...

Screenshot:
image description

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-11-15 23:13:11 +0100

Opaque gravatar image

updated 2019-11-15 23:13:42 +0100

Hello,

from my perspective font Liberation Sans does not contain character U+2694 and thus LibreOffice makes a replacement from another font. Try font DejaVu Sans Mono and you should get what you are looking for.

Background: Not all fonts contain all characters and to circumvent the situation of a missing character in a font given, Libreoffice replaces the missing characters from a similar font (which isn't always a perfect replacement). You may check whether a font contains a special Unicode character in dialog Insert -> Special Character and by selcting the Font and entering the Unicode under Hexadecimal.

Hope that helps.

edit flag offensive delete link more

Comments

Thanks for the information! The information both helped to understand and mitigate the problem.

marcusman gravatar imagemarcusman ( 2019-11-16 17:27:36 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-15 21:51:11 +0100

Seen: 24 times

Last updated: Nov 15