Ask Your Question
0

Numpad in Libreoffice for Mac, how to change decimal

asked 2019-12-02 11:50:33 +0100

Dutch gravatar image

I'm using a Microsoft Sculpt desktop with my MacBook Pro. Lovely keyboard, great mouse, handy numpad but unfortunately both Microsoft and Apple deny the users a driver, so several buttons are annoyingly non-functional.

My pertinent issue is: in mainland Europe most of us use comma's for decimals.

In Word and Excel the numpad key jots down a comma as I want.

But in LibreOffice it provides a dot. There is no Options in the Tools menu, no Locale or Decimal setting to be found anywhere. How do I get it to do the comma? What am I missing?

edit retag flag offensive close merge delete

Comments

I've edited my question since I've found the Language settings in the Tools settings, but checking the decimal locale did not change the character from my numpad. This edit of my question is not showing up when I opened my own question from another Google search.

Dutch gravatar imageDutch ( 2019-12-02 12:16:16 +0100 )edit

You need to mention the Locale of your LibreOffice instance. It seems you have some English (US) settings. Please provide at least:

  • Info from Help -> About LibreOffice (the info which can be copied)
  • Info from LibreOffice - Preferences -> Language Settings -> Languages -> Option: Locale Setting
  • Info from LibreOffice - Preferences -> Language Settings -> Languages -> Option: Decimal Separator

Assuming "Nomen est omen" you may want to set LibreOffice - Preferences -> Language Settings -> Languages -> Option: Locale Setting -> Dropdown: Dutch(Netherlands) :-)

Opaque gravatar imageOpaque ( 2019-12-02 12:23:15 +0100 )edit

I have it on Dutch. I think it sets the local language on install, but it's been a while since I installed it. Version: 6.3.3.2 Build ID: a64200df03143b798afd1ec74a12ab50359878ed CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US Calc: threaded

Language: Default - English (USA) Locale Setting: Default - Dutch (Netherlands) Decimale separator key: [checked] Same as locale setting (,)

Can't add a screenshot, can I? Here's trying

Dutch gravatar imageDutch ( 2019-12-02 22:54:53 +0100 )edit

I've just tried again and Word and Excel are also not displaying the comma. Could have sworn they did. I added the button to Karabiner and having it swap the point for a comma. It works. Still wonder if there's an easier way.

Dutch gravatar imageDutch ( 2019-12-02 23:10:36 +0100 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2019-12-03 11:50:55 +0100

petermau gravatar image

updated 2019-12-05 12:58:16 +0100

What Language is the Mac system? Is it Dutch or American? What language is the physical keyboard? What language is the keyboard setting? Have you defined the keyboard to the system? You say that there is no software support for the keyboard so I wonder how it knows what keys you are pressing with Num Lock pressed. I would expect the system to default to American settings and LibreOffice is probably just seeing a full stop and is not given a decimal point. I hope I am wrong.

It is the operating system that controls the value of the keys pressed on the keyboard. This is partially controlled by keyboard language specified and any overrides you have made. On my Linux/Mint system I use the KEYBOARD command to manage the keyboard. So when I unplug my English-UK keyboard and replace it with a French-France keyboard I need to tell the system to switch the settings.

Also you need to select the correct country as English (UK) is not the same as English(USA) especially the punctuation and currency keys.

When you enter numbers, the keys for comma and full stop are different and their meaning will depend on the software program and language settings. This is NOT the same as using the NUMERIC LOCK on the numeric pad. You can control the meaning of these characters using the KEYBOARD command (on my system, the details may differ depending on the system used).

In particular, on the NUMERIC KEYPAD there is a DELETE key next to the 0/insert key. It is this key that is used to insert the Decimal Point/Comma character when the Numeric Lock key is pressed. This is usually set to DEFAULT and this will give a point or comma depending on your default. You can adjust this to suit or even for both using the shift key option.

So, if you are having problems with the Point/Comma, change the system keyboard settings.

====================================================== My understanding is that Apple Mac keyboards do not support the normal Num Lock key. Therefore you probably would need special support to change the default decimal point.

edit flag offensive delete link more

Comments

MacOS is in Dutch. Interface is in Dutch, Language and Region is in Dutch, advanced settings: grouping (thousands, etc) is set to . while decimal is set to , all as it is supposed to be in Dutch language.

In MacOS you need to set a keyboard before you can use it. IIRC, if MacOS doesn't have a profile for the keyboard (ie, not an Apple keyboard) it asks what button is next to the shift key. That determines whether you have a large, two story Enter button and such. mys Sculpt has the small enter key with the | \ key above it. Sculpt Desktop is in USA keys, which is most used in NL anyway. Numlock on the Num pad is one of those non-functional keys. I guess that should be available in another way, but I don't use that much so never searched. Karabiner is an app for MacOS ...(more)

Dutch gravatar imageDutch ( 2019-12-04 00:43:21 +0100 )edit
0

answered 2019-12-05 10:43:25 +0100

Dutch gravatar image

In the mean time I've found that none of the apps I use (LibO, Word, Excel) replace the period on the numpad with a comma. I could have sworn at some time one did, but now I can't find it. Maybe I replaced a memory from whence I was still on windows. Anyway, I think it is not a LibreOffice problem, just a Mac not wishing to cooperate with anything non-Apple. Believe me, I know. Not a fan-boi. I do blame Microsoft for not releasing a driver, which they did do for other desktop sets.

Answer: I found a solution in Karabiner, which is a button re-mapping software. It is of coarse a key-logger of sorts, but I think they are trustworthy, nothing happened to me yet, I've been using it for years. I use it to remap the ctrl button to the cmd command and the alt button to... Alt command... And now the numpad period to the comma.

There is a remapping feature in MacOS, but I haven't found the numpad period on there.

edit flag offensive delete link more
0

answered 2019-12-03 12:26:51 +0100

The two settings that you show on your screenshot that I copy below:

image description

actually are meant to control which character gets inserted when you press . key on numpad. As described in the relevant help topic, when Decimal separator key: [x] Same as locale setting is checked, the locale selected just above defines which character will be inserted. If unchecked - you will get what keyboard driver supplies.

So in theory, given that Dutch has , as decimal separator in LibreOffice, it should just work. If it doesn't, I could suppose three possibilities:

  1. It actually works, and inserts correct ,; but then, when the decimal number is recognized, it is displayed formatted according to the settings of document/cell - and possibly you use e.g. en-US settings for documents.
  2. It doesn't work, because your keyboard (driver) doesn't differentiate between normal dot key and numpad dot key.
  3. There is a bug in LibreOffice e.g. on macOS - then file a bug please.
edit flag offensive delete link more

Comments

See my other comment, the keyboard sends different messages for the period and the comma, the numpad sends yet another for the period. It's identified as keypad_period by Karabiner. I have no idea where I should select or deselect a en-US Setting for documents. So I guess it's a bug. Can't believe nobody else ever ran into it.

BTW, the numpad is an entirely different unit from the main keyboard. The desktop is comprised by a keyboard, a mouse and a numerical keypad. All three separate and wireless. Marvelous set. Just Mac users are totally ignored by both Apple and Microsoft.

Dutch gravatar imageDutch ( 2019-12-04 00:52:33 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-12-02 11:50:33 +0100

Seen: 36 times

Last updated: Dec 05