Why Are "Short Dates" Getting Entered As Text Rather Than Adding The Year?

asked 2019-12-03 05:19:36 +0100

webmonk gravatar image

updated 2019-12-03 05:25:09 +0100

I have been using LibreOffice Calc for years. When I enter a "short date" (DD MMM) into a column that is formatted as a date type (DD-MMM-YY) it has historically added the year automatically. But sometime in the past month or so things changed. Now it simply turns it into a text string. For example I enter 10 dec and it converts it to '10 dec rather than 10-Dec-19. Strange thing is that if I turn around and enter the exact same thing again it actually adds the year like I would expect. Why do I have to enter it twice? Why did it stop converting it when entering it the first time?

How do I get it operating back the way it used to?

I am using Windows 10 and using LibreOffice version 6.3.3.2 (x64). The Calc file format is ODS. Note that I have already updated to the latest version several times without the issue being resolved.

edit retag flag offensive close merge delete

Comments

Questions related to calc dates never can be seriously answered without information about specific language settings. So please provide information about:

  • Tools ->Options -> Language Settings -> Locale setting -> Dropdown: <what is here>
  • Tools ->Options -> Language Settings -> Date acceptance pattern -> Input fieid: <what is here>
  • Language setting in your Default cell style (if using templates)

In your case it seems: 10 dec is not recognized as a date according to your specific date acceptance pattern and thus kept as text and not turned into an integer (dates in Calc are integers [!] and thus conversion needs to take place, if you enter a date in a human readable format). From your habit, I'd assume, that you are using English (US) flavor of the English language in your LibreOffice settings, while you should use something similar to English (UK), where it is common to have day before ...(more)

Opaque gravatar imageOpaque ( 2019-12-03 11:42:13 +0100 )edit

Thank you. That solved my problem. For the record, these were my values.

  • Locale Setting: Default - English (USA)
  • Date Acceptance Patterns: M/D/Y;M/D

I added "D M" to the acceptance patterns and it now works.

If nobody answers my second question about this issue I'd still walk away happy, but oddities like this make me want an answer. When I entered "10 Dec" and hit tab it saved it as text. If I went back to the cell and did the exact same thing again it would convert it to a date as I wanted. Why would it convert it on the second attempt but not the first?

Thanks for the solution to my core issue!

webmonk gravatar imagewebmonk ( 2019-12-04 02:40:40 +0100 )edit

I cannot confirm / reproduce your observation about "doing the same thing a second time and it works" (even I can't imagine why)

Opaque gravatar imageOpaque ( 2019-12-04 09:10:46 +0100 )edit