Ask Your Question
1

Modifying paragraph style doesn't change paragraph appearance [closed]

asked 2013-08-30 00:18:19 +0200

EricRFMA gravatar image

updated 2015-08-25 19:55:39 +0200

Alex Kemp gravatar image

Hello... When I go into the "Paragraph & Styles" window, and right click on an existing style, and choose modify, change some value(s) and click "Apply" (or "OK"), I don't see any changes to my document. This even happens if I choose some ridiculous value (like indent 2") that I'd be certain to notice.

If I change the values for a specific paragraph via Format->Paragraph, the changes are immediately visible.

Interestingly, if I change the actual paragraph style of an existing paragraph to the paragraph style I'd previously modified, the modifications are apparent in the paragraph whose style was changed.

If I create a new paragraph with the modified style, the changes aren't visible if I put the new paragraphs between two other paragraphs with the modified style. If I create a paragraph where the paragraphs before and after are a different style, then the new paragraphs show the modified style.

The style is not linked with any others, and the next style is the same style. AutoUpdate is off.

It appears, according to my limited experimentation, that the modified style does not change the appearance of existing paragraphs with that style, just newly created paragraphs with that style or paragraphs whose style is changed to the modified style.

Some other notes: Most of the changes I've tried (that don't appear when I make them and click "Apply" or "OK") are in the "Indents & Spacing" tab, specifically the below paragraph value. If I change the font, and click "Apply", that does appear immediately in all paragraphs with the style I'm modifying. Unfortunately, if I click "Reset" then "Apply" again, to get my previous font back, the changes do not appear. I have to Cancel out of the Paragraph Style dialog, and then Undo to get my original font back.

Is there something I'm doing or might have done to get this weird behavior? I thought the purpose of paragraph styles was to do exactly when I'm trying to do.

Using LibreWriter in LibreOffice 4.0.5. This also happened in 4.0.2. On Mac OS 10.7.5.

Thanks for any help anyone can offer

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 16:22:33.827140

7 Answers

Sort by » oldest newest most voted
2

answered 2013-08-30 02:03:08 +0200

carnendil gravatar image

updated 2013-10-21 22:34:24 +0200

In my experience, what you describe is how LibreOffice (and OpenOffice before it) behaves: if you had adjusted the properties of a particular paragraph via menu, that paragraph will not show changes done later on its original paragraph style (e.g. via the Styles and Format box -- F11).

Most of the time, by selecting the offending paragraphs and then double-clicking (on the Styles and Format box) or clicking (on the style drop-down -- see image below) the style of interest, the desired change will take place.

However, not all properties of the paragraph might update. In such cases, mariosv's recommendation to clear formatting, either from the menu or from style drop-down, is the solution.

libreoffice style drop-down

Image credit: Wiebe, Andreas. "Applying Paragraph and Font Styles". EndUserGuides.com.

edit flag offensive delete link more

Comments

1

To add to what @carnendil states, direct formatting (via toolbar or the menu) overrides any applied style. To remove direct formatting you must clear it as @mariosv indicates, and then re-apply your required style.

oweng gravatar imageoweng ( 2013-08-30 02:53:53 +0200 )edit
1

answered 2013-08-30 05:38:28 +0200

EricRFMA gravatar image

You guys are awesome!

Thank you, that was precisely the problem, and, if I think about it long enough it kind of sort of makes sense.

Though it does make it difficult if, say, you have a paragraph in a particular style, and you put some phrase in bold. Then you want to change the style to maybe change the margins or indent. That will work on all other paragraphs in that style that have no direct formatting on it, except that one. If you have a huge document, that might be a bad thing.

Is there any way around this for the type of example above? That is, preserve direct formatting on a paragraph when a style change wouldn't affect the direct formatting. And vice versa, changing a paragraph style would still be applied as long as it wouldn't interact with any direct formatting that was done on the paragraph. I don't know how this works in the great wide world of word-processing, but it seems to my naive mind a little more intuitive.

In my case, it's a short document so I just selected the text in each relevant paragraph and did Ctrl-M as suggested, but still had to go back put some things back into bold.

Thanks again for your rapid and helpful responses!

-Eric

edit flag offensive delete link more
1

answered 2013-08-30 01:25:16 +0200

m.a.riosv gravatar image

Have you tried clearing the direct formatting? Menu/Format/Clear direct formatting [Ctrl+M].

edit flag offensive delete link more

Comments

it doesn't help in my case: the paragraph showing the issue has "Default Style". This style has all indent attributes set to zero. However the paragraph has non-zero indentation exactly like the one above (it has "List paragraph" style by the way). I press Ctrl-M and indentation is still the same non-zero. Re-applying "Default style" after CTRL-M doesn't help as well

vak gravatar imagevak ( 2014-08-22 13:28:30 +0200 )edit

Please can you share a sample file with the issue?, before delete any personal information.

m.a.riosv gravatar imagem.a.riosv ( 2014-08-22 13:43:41 +0200 )edit
0

answered 2014-05-12 08:29:20 +0200

Googly Googly gravatar image

When a paragraph or any style is not getting applied, it means you have some direct/manual formatting there. Manual/direct formatting has overriding preference, which is logically required. Hence, if you want the style to take effect, just select the para, text etc and remove all direct formatting by pressing Ctrl+M or Format>Clear Direct Formatting or you may apply default style first and then apply the desired style. Its really confusing for the new comer to understand this. It sometimes cause hatred for using style. But, this simple thing will set it right.

edit flag offensive delete link more

Comments

it doesn't help. See the details in comment to mariosv's post above.

vak gravatar imagevak ( 2014-08-22 13:31:59 +0200 )edit

did you work out a solution to this, I am having the same problem, will

will2b gravatar imagewill2b ( 2014-09-03 14:46:00 +0200 )edit

The solution that I find si selecting all the text, copy it and paste in a new document. Or selecting all the text, copy it, paste in other application like Wordpad, select all, and copy and paste in new Libre Office document. This clear all the fucking indesired styles. Hope can help :S

FerNET_ gravatar imageFerNET_ ( 2015-05-05 16:25:12 +0200 )edit

I had also this problem with the styles. Attempt to apply a style with defined paragraph indentation was not working and. Using the "Clear direct formatting" did not work, neither trying to apply the default style. The only solution I found was to copy and "paste as" unformatted text. It looks like the "Clear formatting" function is not working properly.

perdigao1 gravatar imageperdigao1 ( 2017-09-04 17:11:43 +0200 )edit
0

answered 2016-01-15 05:25:00 +0200

With version 5.0.4 of Libreoffice, the same problem was occurring even when clearing all direct formats. The issue is that the "List Styles" is over riding the "'Paragraph Styles'. Different styles can be selected with the icons under the "Styles and Formatting" (F11 to bring up). In my case, I needed to select the "List Styles" and select "Modify", then select the "Default" button and Apply. After this the "Paragraph Styles" would word to set the indention since the "List Style" default is to not apply anything.

edit flag offensive delete link more
0

answered 2014-12-05 12:26:29 +0200

Googly Googly gravatar image

When desired para style is not getting applied, After pressing Ctrl+M (i.e. remove direct formatting) I keep applying various existing para styles like Default, Heading 1, Heading 2 etc and then I apply the desired style. So far it has worked for me.

edit flag offensive delete link more
0

answered 2014-09-03 14:43:58 +0200

will2b gravatar image

updated 2014-09-03 14:47:11 +0200

did you work out a solution to this, I am having the same problem, reformatting everything does not work for me will

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-08-30 00:18:19 +0200

Seen: 11,309 times

Last updated: Sep 03 '14