Ask Your Question
1

Spell check for English (India) [closed]

asked 2013-09-07 21:27:48 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Does libre Office writer has English (India) spell checker?

After posting this question i got two suggestions (answeres). the 1st one i have all ready used and not applicable for English (India) dictionary. In case of second it indicates to me that i can use v 4.1..... which will help me in finding the dictionary i want. i tried installing that version......... i has failed. details of my efforts (of installing 4.1..... 1. Open Terminal with pressing CTRL+ALT+T. 2. Copy bellow command and paste to terminal and press Enter to add libreoffice-4-1 PPA: sudo add-apt-repository ppa:libreoffice/libreoffice-4-1 3. Then copy bellow command to update software to new version: sudo apt-get update && sudo apt-get -y dist-upgrade

in spite of these efforts I am still running 4.0.2.2!! now what?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-08 05:38:00.265790

Comments

I have now successfully installed 4.1.1. But still it has no English (India) language option installed. I can see it in the list of directories - Tools > Options > Writing Aids > Available Language Modules > Hunspell spellchecker > edit > "no option for English (India)

And down under the same tab of writing aids under the heading user difined dictionaries if I try to add new one, in the list I can see English (India) as Option but it is not marked. In other words its of no use. it will not correct my spellings like English (Uk) or (US) can.

sangharsh gravatar imagesangharsh ( 2013-09-13 15:44:42 +0200 )edit
manj_k gravatar imagemanj_k ( 2013-09-19 14:58:54 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-09-08 05:45:57 +0200

oweng gravatar image

The "English (India)" entry in the list of dictionary options indicated by @mariosv is simply an option to use the en-GB dictionary for the en-IN locale i.e., there is no en-IN dictionary. If you have downloaded a non-English version of LO, then you will need to additionally download the en-GB language pack that includes en-AU, en-CA, en-GB, en-US, and en-ZA dictionaries to support an even longer list of locales.

The en-GB language pack for v4.1.2.1, in DEB format, for the x86-64 architecture, can be found here. If that is not the particular one you require, just navigate your way back up the directory tree and down again to the one suitable for your installation.

edit flag offensive delete link more

Comments

the version i am using is 4.0.2.2. it doesn't have English (India) dictionary and extension is not available. Does that mean i can not run spell check with English (India) in libreoffice?

sangharsh gravatar imagesangharsh ( 2013-09-11 08:56:13 +0200 )edit

English (India) dictionary = English (UK) dictionary. You do not need to use v4.1.2.1 or upgrade to this version. I simply linked to that as it is the current (latest) version right now. It sounds like you are running from PPA so you will need to locate the "en-GB" language pack for your release.

oweng gravatar imageoweng ( 2013-09-13 03:59:48 +0200 )edit

@oweng I don't agree with English (UK) = English (India)

sangharsh gravatar imagesangharsh ( 2013-09-13 16:42:27 +0200 )edit
1

I did not mean to imply the languages are the same (as in the real world there are evidently differences). I meant to indicate in both my answer and comment that LO uses the UK dictionary for the IN locale, so in LO the dictionaries are the same. If you open up the en-GB language pack (libreoffice4.0-dict-en... DEB file) you will not find an en-IN .dic file, but you will find the en-GB .dic is being used for these locales: en-GB en-BS en-BZ en-GH en-IE en-IN en-JM en-NZ en-TT.

oweng gravatar imageoweng ( 2013-09-14 00:48:07 +0200 )edit

@oweng thanks.

sangharsh gravatar imagesangharsh ( 2013-09-18 17:47:24 +0200 )edit
1

answered 2013-09-07 22:09:14 +0200

m.a.riosv gravatar image

updated 2013-09-08 01:25:37 +0200

Have you trying to select it?

Menu/Tools/Options/Language settings/Language - Default language for documents.

It is possible to select also in Font tab for paragraph styles or character styles.

And take a look to the documentation is always a good help:
https://wiki.documentfoundation.org/Documentation/Publications#LibreOffice_Writer_Guide

Edited.

Select languages dictionaries is available when you are doing the installation.

Reinstall LibreOffice, select personalized installation, and in the optionals components it is possible to select what dictionaries install.

edit flag offensive delete link more

Comments

I have selected it as default language. But the problem is English (India) is not an installed dictionary (it does not shows tick mark in front of it in list of dictionaries.

sangharsh gravatar imagesangharsh ( 2013-09-08 00:27:16 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-09-07 21:27:48 +0200

Seen: 927 times

Last updated: Sep 11 '13