Ask Your Question
0

Default currency set but LO still enters wrong currency

asked 2020-02-21 02:54:20 +0100

Earnest Al gravatar image

updated 2020-02-21 05:11:37 +0100

Hi.

I have LO 6.3.4.2 recently installed on a new Windows 10 PC. I have set the default currency in Tools|Options to "Default - NZD" but the Number Format - Currency icon inserts £ (UK pounds). How can I set it to $ (dollars)?

Example: I open a new Writer document. Insert table, enter a number, click on the "Number Format: Currency" icon and I get a UKP symbol in front of the number. I need a dollar symbol.

New info: Calc enters $ (dollar symbol) using currency icon now but, sadly, not Writer

Thanks for your help, Al

Further info

In Tools|Options...|Languages I have tried in User Interface both: English USA and English UK. Locale Setting is English New Zealand. In Default Language for new documents I have English (UK) to take advantage of the wider range of language tools. There is very little, if any, difference in grammar and spelling. But I do want NZ dollars as default C:\fakepath\UKP_not_Dollars.png

In Windows 10, despite its best efforts, I have English NZ set as default language and US keyboard. The default currency symbol is $ (dollar symbol)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-02-21 08:30:01 +0100

Number Format: Currency does not use the default currency set in the options; it takes the language of text in cell into account. And if you have your system input language set up in Windows incorrectly (e.g., to be en-UK when you need it en-NZ), and also do not ignore system input language in language options of LO, it would set language in cells automatically to, say, en-UK, and so the currency inserted would be UK pounds.

You need to either ignore system input language in LibreOffice settings (a bad option IMO), or set up your input language in Windows correctly to en-NZ (in Language and Keyboard system settings).

edit flag offensive delete link more

Comments

In Default Language for new documents I have English (UK) to take advantage of the wider range of language tools

So you could have the language of text set to en-UK on purpose. I suppose that you can't have what you want using the built-in command - which is designed to use current cell language. You might need to create a custom macro for that.

Mike Kaganski gravatar imageMike Kaganski ( 2020-02-21 09:41:56 +0100 )edit

Thanks for your time and the explanation. So I can write a short macro and attach that to a custom icon which would work in a similar way to the currency icon.Or embed a Calc sheet each time which gives correct dollar sign and extra functionality

I think I'll try the macro first

Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-02-21 11:47:35 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-02-21 02:54:20 +0100

Seen: 92 times

Last updated: Feb 21 '20