Have LO 6.4.93 (x64) can't find JRE

asked 2020-02-26 16:29:10 +0200

Islandbnd gravatar image

I have Windows 10 Home, Version 1909, OS build 18363.657 with latest updates, JRE Version 8, Update 241, Build 1.8.0_241-b07, installation checks valid. I have installed LO 6.4.03(x64).

I have removed, both LO and JRE in various orders and it keeps saying "LibreOffice requires a 64-bit Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice" and Base will not build a file.

edit retag flag offensive close merge delete

Comments

Have you checked option [x] Use a Java runtime environment ticked at Tools -> Options -> LibreOffice -> Advanced? Is the radio button checked leftmost of the JRE in the pane below?
And (most important): Have you really installed the 64-bit JRE (32-bit JRE doesn't work with 64-bit LibreOffice)? Please tell the name / link of the JRE you have downloaded and installed.

Opaque gravatar imageOpaque ( 2020-02-26 16:36:06 +0200 )edit

Yes, the radio button is checked and the installed JRE box is blank. If I try to add and navigate to c:/Programs Files/Java/jre1.8.2_241 I get "The folder you selected does not contain a Java runtime environment. Please select a different folder." This is exactly where the JRE is installed. I downloaded the JRE from this location: https://www.java.com/en/download/wind...

Islandbnd gravatar imageIslandbnd ( 2020-02-26 16:51:52 +0200 )edit

This file jre-8u241-windows-x64.exe - just tested that, and got no problem on Windows 10, 1909, 18363.657 (Pro) ? And LibreOffice does recognize without Add and searching for the JRE (as its designed to work).

Opaque gravatar imageOpaque ( 2020-02-26 17:03:42 +0200 )edit

What do you get, when executing "%ProgramFiles%\Java\jre1.8.0_241\bin\java" -version (including quotes) on a Windows terminal?

Sample output on my system:

java version "1.8.0_241"
Java(TM) SE Runtime Environment (build 1.8.0_241-b07)
Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)
Opaque gravatar imageOpaque ( 2020-02-26 17:12:13 +0200 )edit

I realize it SHOULD, but it isn't recognized. Could it be a difference between Win 10 Pro and Home?

Islandbnd gravatar imageIslandbnd ( 2020-02-26 17:13:05 +0200 )edit

Now again I need to answer "it should" not matter. Did you already try to reset (through Help -> Restart in Safe Mode) your LibreOffice user profile (corruptions in user profiles may really have very strange side effects) and please provide the requested information (filename installed and output from the command).

Opaque gravatar imageOpaque ( 2020-02-26 17:30:20 +0200 )edit

java version "1.8.0_241" Java(TM) SE Runtime Environment (build 1.8.0_241-b07) Java HotSpot(TM) 64-Bit Server VM (build 25.241-b07, mixed mode)

Get same error in Safe Mode: "LibreOffice requires a 64-bit Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice."

Islandbnd gravatar imageIslandbnd ( 2020-02-26 17:37:06 +0200 )edit

Safe Mode doesn't automatically check/activate the radio button(s), even if it finds Java. Thus: Did you re-check the settings in Tools -> Options -> LibreOffice -> Advanced?

Opaque gravatar imageOpaque ( 2020-02-26 17:43:17 +0200 )edit

Yes, I checked and the radio button is checked and I tried to add a JRE after checking the option to reset the user profile after going in to safe mode.

Islandbnd gravatar imageIslandbnd ( 2020-02-26 17:45:45 +0200 )edit

Sorry but your comment confuses me: If you have no JRE found then there is no radio button to check. Could it be, that you mistake radio button with option/check box? And re-reading above you mention: c:/Programs Files/Java/jre1.8.2_241, which seems to be wrong or a typo (1.8.2 vs. 1.8.0)?

Opaque gravatar imageOpaque ( 2020-02-26 17:52:38 +0200 )edit