Ask Your Question
2

Install via group policy: where are the language transform trans_xx.mst files [closed]

asked 2012-05-02 07:37:40 +0100

cosmos gravatar image

updated 2015-08-28 18:47:10 +0100

Alex Kemp gravatar image

In the .exe bundled installation packages, one could unpack and find inside trans_XX.mst transform files, one for each support language. I used one of them to transform my group policy-based installation, as follows, in order to install Greek:

msiexec /i <libo.msi> TRANSFORMS=trans_el.mst /qn

(The installation was made via a group policy, but in essence that's what happened).

In LibO 3.5 no such files exist. How should I install a single language in this case?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 00:09:47.219381

Comments

@cosmos -- Did you ever find an answer for your question? Still interested in finding an answer for it?

qubit gravatar imagequbit ( 2013-03-10 10:03:44 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2012-05-04 07:01:40 +0100

cosmos gravatar image

I am a network administrator for my LAN and have been downloading/installing Oo for the last 4 years or so. So I (think I) know the procedure pretty well more or less.

But for the record and to answer your question, I always download from http://www.libreoffice.org/download/. The specific file I had downloaded was named LibO_3.5.2_Win_x86_install_multi.msi

Does this MSI contain the trans_XX.mst transforms?

edit flag offensive delete link more

Comments

1

Nope, it doesn't. Ever since installable files are MSI ones, there are not trans_XX files given

cosmos gravatar imagecosmos ( 2012-06-10 19:08:03 +0100 )edit
0

answered 2012-05-02 08:27:26 +0100

mahfiaz gravatar image

Are you sure you didn't download the English-only version and your download link was something like:

http://download.documentfoundation.org/libreoffice/stable/3.5.2/win/x86/LibO_3.5.2_Win_x86_install_multi.msi

edit flag offensive delete link more

Comments

Yep, I'm sure.

cosmos gravatar imagecosmos ( 2012-06-10 19:08:25 +0100 )edit
0

answered 2012-05-04 10:04:22 +0100

manj_k gravatar image
edit flag offensive delete link more

Comments

I know about the latter; I am one of the bug contributors. Seems like part of it is by design and the newer libo does not utilize trans_XX files anymore.

cosmos gravatar imagecosmos ( 2012-06-10 19:07:12 +0100 )edit
1

fdo#40481 has status RESOLVED FIXED.<br> fdo#50509 - Language selection is not possible with silent install has status RESOLVED FIXED.

"guessing heuristic is switched off, and user can define explicitely,
what languages should be installed.

E.g.:
    msiexec /i LibO_...._.msi UI_LANGS=en_US,de,fr,hu

This will install English (US), German, French, and Hungarian."
qubit gravatar imagequbit ( 2013-03-13 07:22:29 +0100 )edit

See also: Follow-up Bug 54585 - UI_LANGS has no effect on update

Status: NEW

"UI_LANGS works fine if there is no LO installation present on a computer. But, if there is an installation already, UI_LANGS doesn't change UI languages. [...]"

manj_k gravatar imagemanj_k ( 2013-10-22 23:54:20 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2012-05-02 07:37:40 +0100

Seen: 2,102 times

Last updated: May 04 '12