Ask Your Question
0

Use different script for numbers for chosen cells (Khmer instead of Arabic) in calculator possible? [closed]

asked 2020-03-07 05:37:30 +0100

updated 2020-11-26 22:53:20 +0100

Alex Kemp gravatar image

Valued team and members here,

is it possible to use another script (say Khmer) for calculation formulas and all other performances aside of simply for text parts? Usually, if enter a Khmer number it would be rendered back to roman script if the cell isn't marked as containing text.

If such is possible, how could it be set to work.

What ever hints and tips more then welcome.

(Screenshot provides a view how Mr. Lupp's solution could solve the problem. Sadhu! Screenshot settings

edit: activated screenshot -AK)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-11-26 22:53:36.556201

Comments

As it seems: it can be solved by setting 'general options' - 'numbers' to "system" (instead of arabic...) inside the menu 'extras' - 'language settings' - 'complex text layout', but as it seems it changes all numbers anywhere and does no more allow arabic.

Samana Johann gravatar imageSamana Johann ( 2020-03-07 13:03:04 +0100 )edit

Did you actaully EDIT the question's content or just "bump"?
I cannot find the difference based on my memories.

Lupp gravatar imageLupp ( 2020-03-08 15:40:18 +0100 )edit

My person edited the title, Mr Wolfang ( @Lupp ) "for chosen cells", since general change isn't desired.

Samana Johann gravatar imageSamana Johann ( 2020-03-09 10:55:46 +0100 )edit

This was a good idea. You might also consider to clarify the usage of "Roman". The Western tradition speaks of "Roman numbers" if "Roman cyphers" are used. E.g: 1944 = MCMXLIV. It's only kind of funny historicism, but still used by few persons in a few special cases. The decimal digits used in Western civilization and partly world-wide now are also known as "Arabic" here. That's because they were brought to us from India via the Islamic culture of Arabs (and later modified in different ways, of course) . In this special case diversity is a pity. "Roman" notation is a disease.

Lupp gravatar imageLupp ( 2020-03-09 13:02:56 +0100 )edit
1

The screenshot attached to the question by editing is showing that the OQer uses a German UI and has set Khmer as the locale. Otherwise the 'Language' field of the dialog would only display 'Khmer' instead of 'Standard - Khmer'. (In English UI 'Default - Khmer').
I would like to hint that the solution also worked for me having set the locale to 'English (UK)'.
(I use the mentioned settings despite the fact that I am a German living in Germany. Using Eglish UI and English locale significantly facilitates participation in international cooperation. Everything I need to be "German" I can set below the level of UI and locale.
Localization beyond the absolutely necessary is an evil.)

Lupp gravatar imageLupp ( 2020-03-09 13:54:31 +0100 )edit

Sadhu for all effort and liberality in giving what ever hints Mr. Wolfgang finds as helpful.

Samana Johann gravatar imageSamana Johann ( 2020-03-09 14:14:45 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-03-07 12:32:50 +0100

Lupp gravatar image

updated 2020-03-09 13:15:55 +0100

(I don't know anything about Khmer language/script. And I would prefer a world where at least information based on numerals can be communicated without cultural barriers. Did you use the term "Roman" meaning "Latin script" or "Western script"?)

Did you try the prefix [NatNum1] to 'number' format codes used in cells set to Language = Khmer?

===EDIT 2020-03-09 about 12:15 UTC===
See also this attached example.
Regard the usage of cell styles. It's the way to do it in Calc.

edit flag offensive delete link more

Comments

Appreciation for hints. My person is not sure what Mr Wolfgang might think about, guessing it's about general setting, but will certain look into this area with the hint in mind and possible approach another time.​They are nice looking btw. ០១២៣៤៥៦៧៨៩.

Samana Johann gravatar imageSamana Johann ( 2020-03-07 12:47:21 +0100 )edit

Just found out that in language settings - complex text settings, if using "system" it seems to adopt the language. But for all numbers everywhere...

Samana Johann gravatar imageSamana Johann ( 2020-03-07 12:58:26 +0100 )edit
1

I will not try with a Khmer UI (if available at all) or with a Khmer locale. I also have no appropriate keybord - and there will be very few visitors to this Q&A who have. But the prefix (I mentioned it above) [NatNum1]to number format strings did a lot for me in cells set to Khmer as the language to use in the 'Numbers' context.

Lupp gravatar imageLupp ( 2020-03-08 15:46:02 +0100 )edit

My person is sure that it would be of help, but has still no idea where to insert the prefix. In the cell? Any settings. May the ignorance be pardoned, Mr. Wolfgang.

Samana Johann gravatar imageSamana Johann ( 2020-03-09 10:58:43 +0100 )edit
1

The "prefix to the number format string" is to enter into the line for editing the number format code under >Format>Cells...>>Numbers tab as the first part of the code.
It works for me (UI=en(UK), locale=en(UK), document language=en(UK)) with ordinary formats. Unacquainted with Khmer language/script/culture I cannot judge if it works with different number format types satisfyingly. It works with ISO 8601 date format, however.
Anyway you need to set (in the same dialog/tab - top right in my version) the 'Language' to "Khmer".

Lupp gravatar imageLupp ( 2020-03-09 12:49:41 +0100 )edit

Sadhu (Ausdruck der Anerkennung und Zustimmung). Although not understanding it at all, it works.

Samana Johann gravatar imageSamana Johann ( 2020-03-09 13:35:02 +0100 )edit

Sadhu! (Ausdruck der Anerkennung, Befuerwortung) Although not understanding at all how it works, it works. (Have attached a screenshot in question)

Samana Johann gravatar imageSamana Johann ( 2020-03-09 13:42:41 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2020-03-07 05:37:30 +0100

Seen: 87 times

Last updated: Nov 26 '20