Ask Your Question
0

getting rid of first page headers

asked 2020-03-23 22:11:33 +0200

feraljazz gravatar image

updated 2020-03-25 00:27:14 +0200

I have a 300 page book and successfully removed first chapter page headers on the first half of the book but headers start again on the last section of stories. I could remove some by placing the cursor in the header and double clicking first page in page styles but eventually that stopped working too.C:\fakepath\sleep talking 27 odt.odt the file sleep talking looks fine in subdocument but has jumbled pages in master doc. I have page breaks at start and end. It is similar to all the other story sections but the first page has a header which I don't want and jumbled up paragraphs which I don't want also. There are thirty five good sections and then five bad. Arrghh...can't I just tweak these last stories and get this completed? I should add that the subdocuments between each story have four art images in each file.

edit retag flag offensive close merge delete

Comments

Share a file. Otherwise you will be the only one who can figure out what the problem is (and you seem to be unable to do it). Most probably, there is some a unwanted page style change (or a wanted style change is missing).

gabix gravatar imagegabix ( 2020-03-24 07:20:10 +0200 )edit

C:\Users\Owner\Documents\john\writing\book\parts 1,2,3\sub documents\subdoc stories\sleep talking 27 odt.odt I hope this works for a link.

feraljazz gravatar imageferaljazz ( 2020-03-24 16:54:39 +0200 )edit

In the sample file that you have shared all pages have the Default style and nothing in the header. That's what should be expected. And, once again, what do you want to achieve?

Read this tutorial and this tutorial.

gabix gravatar imagegabix ( 2020-03-25 07:23:29 +0200 )edit

The sample file shows a complete lack of styles (only paragraph Default Style and page Default Style). This won't allow you to format differently your book parts. The page break after the first page does not switch to another page style.

You seem to use Writer like a mechanical typewriter: vertical spacing with line feeds or empty paragraphs, some indents made of spaces. Also you adhere to a clumsy US convention of double space after full stop. This habit creates problems with modern document processors when justification occurs.

I recommend that you practice the styles system, starting with paragraph styles, otherwise you'll never succeed to format your book. Note that paragraph style Default Style in Writer is reserved for setting defaults for all other styles and must not be used for common text (this role is devoted to Text Body).

Proceed then with page styles. Drill on short ...(more)

ajlittoz gravatar imageajlittoz ( 2020-03-25 08:24:30 +0200 )edit

Thanks ajlittoz.. How do I re-format all the documents so there is not a double space after each sentence? Also in terms of moving blocks of text I have been using shift/enter or control/enter. How else do I move blocks of text around? In paragraph styles I have been using first page and default page. This was by following chapter 8 page 173 in customizing page styles for a book chapter. I will practice on a short group of similar documents like you said and use text body though. One last thing...you said using a page break after the first page does not switch to another page style. So using the manual break and selecting a following style like first page doesn't effect the following pages? Thanks for all your help!

feraljazz gravatar imageferaljazz ( 2020-03-25 15:45:59 +0200 )edit

One more thing in terms of styles. I just want no headers on the first pages of each story, with book title/# on right headers and author/# on the left headers, those would all be the same. No chapter titles. Using body text instead of default, do I just need to designate the image sections as one style and the story sections as another style and then get rid of all my haphazard conglomeration of page breaks?

feraljazz gravatar imageferaljazz ( 2020-03-25 16:14:00 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-03-24 11:04:50 +0200

ajlittoz gravatar image

updated 2020-03-24 11:07:50 +0200

This site already has answers for such a question. Type "header" in the search box at top and select among the results.

To solve your question, you need to structure your document with a combination of page styles and paragraph styles.

A thorough answer is given here. However, to fully understand it, you are encouraged to read the Writer Guide, notably the chapter about styles.

Note that First Page page style is not intended to be used for chapter first page (because it switches automatically to Default Style and this may mess up all your chapter headers) but rather for cover page.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more

Comments

Thanks for the advice. I have read and re-read the manual and used first page style with following pages default, different right and left headers. I am curious why it worked so well through half the book and then stopped. I have been able to force some of the remaining chapters using 'insert, manual break, first page style on the start of those chapters to switch the first page from default to first page. This works on some but others there is an extra page I have to manually delete which of course reappear when I open the document after closing. Let me know if this link works. C:\Users\Owner\Documents\john\writing\book\parts 1,2,3\sub documents\subdoc stories\sleep talking 27 odt.odt I will check out your suggestions and get back to you. Thanks so much.

feraljazz gravatar imageferaljazz ( 2020-03-24 17:24:46 +0200 )edit
0

answered 2020-03-24 03:04:13 +0200

MQ-818 gravatar image

I am not an expert. But did you restart your machine and try it again? In many cases, in the past, restart worked for me!

edit flag offensive delete link more

Comments

Thanks. I have re-opened the file many times but so far it stays the same.

feraljazz gravatar imageferaljazz ( 2020-03-24 04:33:30 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-23 22:11:33 +0200

Seen: 48 times

Last updated: Mar 25