Ask Your Question
1

How do I get rid of the 'extra' chapter number in the Table of Contents? [closed]

asked 2013-10-19 03:44:57 +0200

dmblank gravatar image

updated 2015-11-12 03:49:39 +0200

Alex Kemp gravatar image

In the TOC, chapter entries are show up:

n  Chapter n - chapter title                             pg.no.

The first 'n' (chapter number) is 'extra'. My level 1 Table Entry is defined as:

LS, "Chapter", E#, " - ", E, T, #, LE.

I understand all that (I think) ... Link Start, the text "Chapter", the chapter number, the text " - ", the text of the chapter title, tab to right of page, Link End. That is what I want.

If I don't have numbering enabled in the paragraph style for the Chapter title (or the associated ___ style, I don't recall at the moment), I don't get any chapter numbers period!!. When I enable Numbering, I get chapter numbers ... that part is good, although there are two bad parts ... 1) the chapter titles now have numbers (which I don't want), 2) I end up with the chapter number in the TOC entry twice.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-12 03:49:57.211810

Comments

I should have noted ... LibreOffice, 3.5.7.2

dmblank gravatar imagedmblank ( 2013-10-19 03:48:08 +0200 )edit

Also here it would be helpful if you could upload the file. Ideally include a manually created table which should represent the TOC you want to create automatically. (Be careful about the content of the file; this is a public site!!!)

ROSt52 gravatar imageROSt52 ( 2013-10-19 06:00:25 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-10-19 06:14:25 +0200

oweng gravatar image

updated 2013-10-19 06:15:26 +0200

It sounds to me like you may have numbering turned on for the related Contents N style. As I indicated in my answer to your related question, these are the default styles used by Writer when generating a ToC. You should be able to edit these styles and turn off the leading numbering:

  1. Ensure you have the Styles & Formatting panel open (F11).
  2. Right-click the required style entry (e.g., Contents 1) > Modify... > Outline & Numbering tab > set the Numbering style to "None."
  3. Click OK.
  4. Repeat for each style/level in your ToC.
edit flag offensive delete link more
0

answered 2013-10-19 07:22:02 +0200

dmblank gravatar image

updated 2013-10-19 08:12:56 +0200

oweng gravatar image

I wasn't very clear in my original statement but that is actually the way I started (since I knew I didn't what the chapters numbered in the text).

I did repeat your steps and have developed a work-around. Setting the Numbering style to "None" does get rid of the Chapter number but ... the next time I regenerate the table, ALL Chapter numbers are gone, including the ones I want:

Chapter  - Introduction                             12

Note that not only is the undesired Chapter number gone, but so is the desired chapter number.

The work-around is to "turn on" the Numbering style, generate the table of contents, then "turn off" the Numbering style.

thank you.

edit flag offensive delete link more

Comments

That is odd. It sounds as though your paragraph styles may be defined in a way that has one automatically updating another, although it is difficult to tell without seeing the original document. When you edit a paragraph style, on the Organizer tab is the AutoUpdate option checked?

oweng gravatar imageoweng ( 2013-10-19 08:15:50 +0200 )edit

Leave all Other Idea THere Is Best Thing For table of content management just Check It Out This site

http://index-indent-online.com/

All Solution of table of content issue here!!

shashank gravatar imageshashank ( 2018-03-18 10:34:22 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-19 03:44:57 +0200

Seen: 964 times

Last updated: Oct 19 '13