Ask Your Question
0

LibreOffice is working too slow when I use EPS images [closed]

asked 2012-05-05 14:14:33 +0100

P_Aleksandrov gravatar image

updated 2015-10-16 00:33:48 +0100

Alex Kemp gravatar image

LibreOffice is working too slow when I use EPS images. My document contains 10 images in EPS format (mathematical plots). Cache size for graphical objects is set to 256 Mb. Memory per object: 100 Mb. System: 2 Gb RAM, Ubuntu 12.04. LibreOffice version is 3.5.3.2 from Ubuntu repositories. Ocular (from KDE) works normally when I see this document converted to PDF. The conversion is done with "Print to file" and ps2pdf. If I am not mistaken, vector images are not converted in raster when I convert the document to PDF by this way. Is it possible to increase speed?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 00:34:24.539886

1 Answer

Sort by » oldest newest most voted
2

answered 2012-05-05 14:32:15 +0100

caolan gravatar image

The eps files probably don't contain raster previews, so ghostscript is getting spawned off to generate some to show on-screen, which I admit is something of a bodge :-)

You could use epstool to add previews to your eps files to see if that helps.

edit flag offensive delete link more

Comments

@P_Aleksandrov, Please feel free to file an enhancement bug and ask for speedier handling of documents containing EPS documents. No guarantees on when an improvement might be landed, but by reporting it, the request is at least on our radar :-)

qubit gravatar imagequbit ( 2013-02-17 06:12:15 +0100 )edit

Question Tools

Stats

Asked: 2012-05-05 14:14:33 +0100

Seen: 770 times

Last updated: May 05 '12