Ask Your Question
0

libreoffice writer documents open with different fonts than were saved

asked 2020-05-27 11:16:32 +0200

johnstonstever gravatar image

updated 2020-05-28 00:08:09 +0200

When I open libreoffice writer documents, blank lines on the document will have bold, different fonts, and/or spacing below lines that were not entered, and are not desired. The program is doing this "automatically" for some unknown reason. New information- My libreoffice shows 6.2.3 win x64. I do not know the meaning of "OS" in your comments. By blank lines I mean lines without text which are used to separate sections of text. A document was saved as docx. It contains text, a table, and several photographs. When saved, font was verdana 10 with no bold. It was then closed. When opened, again, the cursor was clicked on the blank lines. Beginning at the 6th blank line, the next few showed verdana 10 bold. Typing in those lines produced bold text. The document was corrected, again, but when reopened, the bold reappeared. It was also saved as .dot. At the 6th blank, the font was not bold, but was sized 12 vice 10. So how do I save documents such that they will open as they were when saved and closed?

Why does this attached document (an example of a frequently encountered issue) open with changes to the font size, the font, and or change to bold after each time it is closed? It is intended to be Verdana 10 without bold. These lines without text are created by what the e-mail I received from libre calls "two consecutive Enters".

C:\fakepath\ZIMMERSTUTZEN1.docx

edit retag flag offensive close merge delete

Comments

1

Have you updated your OS recently? The installed fonts may be different from those when you initially wrote your document. What is your OS and LO version?

You mention "blank lines". They're supposed to be empty. How do you know their font properties are different from the rest?

Edit your question (don't use an answer which is reserved for solutions or comment to start discussion.

ajlittoz gravatar imageajlittoz ( 2020-05-27 11:26:57 +0200 )edit

fonts may be different

…or completely missing. See the font selector on the toolbar. If the font name appears in italic, the font is not available, and LibreOffice tries to find a substitute.

gabix gravatar imagegabix ( 2020-05-27 12:12:34 +0200 )edit

Thanks for your edit.

OS = operating system; you answered "Windows" (but without version 7, 10? Anyway it is already an answer).

Generally speaking, vertical spacing between paragraphs should not be done with blank lines but with modifications of the vertical properties of paragraphs. However this is not where the problem lies.

Please make a sample from your file, reducing it to 2 pages without table not photos, eventually replacing personal data with nonsense text. Then edit again your question to attach this sample to it, using the paperclip tool.

By the way, on this site, a line break is coded as two consecutive Enters. Use this formatting trick to make your question more readable.

ajlittoz gravatar imageajlittoz ( 2020-05-27 18:27:00 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2020-05-28 08:37:42 +0200

ajlittoz gravatar image

updated 2020-05-28 10:34:25 +0200

I have never seen such a file!

When I open it, it pretends that everything is Verdana 10pt not bold, i.e. what you seem to expect. But when you move the cursor through the text, you see that 3 different paragraph styles format the text: Default Style, Text Body and Normal (Web):

  • Default Style: Verdana, 10 pt, regular, no indent, no spacing
  • Text Body: same as Default Style, except spacing below paragraph 0.25cm, line spacing 115%
  • Normal (Web): Times New Roman, 12 pt, regular, no indent, spacing before and after 0.49cm

There are also character styles applied throughout:

  • Default Style: this is a "no-style" telling that the paragraph style is applied unchanged
  • Default Paragraph Font: equivalent to Default Style, does nothing
  • Emphasis:italic
  • Internet Link: light blue, underline, disables spell-checking; this style is automatically applied by Writer when it recognises an URL link
  • Strong Emphasis: Times New Roman, bold

To complicate matters, a direct formatting (manual formatting) has been applied all over the text to "canonise" it to Verdana 10 pt regular. This overrides the original formatting of the document.

To see the original formatting, Ctrl+A then Ctrl+M.

Your document is saved as .docx. This involves a conversion when loading it and a second one when saving it. The foundations in .odt and .docx are not the same and can't be translated with accuracy. In particular Word has no notion of character styles. I don't understand why such styles survive the conversions and this may be the cause of the problem.

Unless you absolutely need to exchange documents with the outside world, always prefer the native format, i.e. .odt. And even in this case, Word can read (and save) .odt documents.

There is also another source of trouble:

  • some spaces are in fact "no break spaces" (Ctrl+Shift+Space) which don't behave like standard spaces, forbidding line wrap
  • line breaks Shift+Enter have been used instead of paragraph breaks Enter, probably to group "sub-paragraphs" together -- this is faulty and betrays a deficient paragraph style set

How to fix your document:

Choose between style formatting and direct formatting. The former is recommended as you'll meet less trouble in the long run.

  • Remove all direct formatting Ctrl+A then Ctrl+M to access the original structure of your document
  • Apply character style Default Style after selecting the whole text; this removes all character styles, maybe leaving hyperlinks marked
  • Apply paragraph style Text Body, the standard paragraph style for document content, to the whole text.

After that, your text has a "neutral" formatting. Save it before continuing. You can then format it to your liking. As mentioned previously, use styles (but save .odt to guarantee round-trip fidelity).

I also recommend you replace the line breaks by ordinary paragraph breaks and the empty spacing paragraphs by an appropriate distance in the above/below spacing attributes of Text Body.

To show the community your question has been answered, click the ✓ next to the correct answer ... (more)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-05-27 11:16:32 +0200

Seen: 51 times

Last updated: May 28