Ask Your Question
0

Custom font takes whole page

asked 2020-06-01 00:48:38 +0200

mhaddad88 gravatar image

updated 2020-06-01 01:05:23 +0200

I am trying to use a byzantine musical font (found here: http://music.stanthonysmonastery.org/...). Each character seems to take the entire height of the page in Writer, so I can only have one line of text before it moves to the next page. When using Microsoft Word, the fonts work just fine and take up the space of the character itself. I would love to get this font working in Writer. Any idea why it may be behaving this way? For testing, use EZ Psaltica from the font package (There are 6 fonts). EZ Omega works fine as it is more of a traditional text font and not musical symbols.

Currently on the latest version of Ubuntu with the pre-installed LibreOffice applications.

edit retag flag offensive close merge delete

Comments

Ok this might work for you. Took about 30 min of playing with some settings for text to figure it out.

There is a template that is included with this font, I'm not certain at this time that it is needed, but there is a macro with it. LO doesnt seem to mind the macro. The font needs a lil tweaking to get a reasonable size. I seems to be related to line spacing and and this can be adjusted.

Select some giant line spaced byzantine musical font characters. Make sure the sidebar is opened, and the text properties portion is active. At the bottom of the dialog is a small drop down with options for setting the line spacing. With the options open, make sure you select the custom value section and the custom spacing is set to FIXED. Now adjust the values with the up down arrows ...(more)

AdmFubar gravatar imageAdmFubar ( 2020-06-01 04:55:14 +0200 )edit

Thank you so much, this worked perfectly!

mhaddad88 gravatar imagemhaddad88 ( 2020-06-01 05:55:34 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-06-01 10:46:08 +0200

ajlittoz gravatar image

The font seems to be faulty: its Descent distance has bee defined negative when it should be positive (font generators are smart enough to know that "descent" goes below the base line) Consistently, Descent HHead is positive while it should be negative.

I don't know if it is the ultimate cause of the bad rendering because I can't save hte patched version of the font. Other errors like auto intersection and bad placement of shape extrema prevent FontForge from generating a new version. There is also a warning about Windows rejecting fonts with an OS/2 version of 0.

EZ Omega has correct metrics settings.

The best thing you can do is contact the font author, telling him about the incorrect metrics settings.

@AdmFubar's workaround does temporarily fix situation but it is "dangerous" to lock line spacing to some fixed value because it will no longer adapt to font size.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more
0

answered 2020-06-01 05:56:53 +0200

mhaddad88 gravatar image

See comment by AdmFubar for answer.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-01 00:48:38 +0200

Seen: 30 times

Last updated: Jun 01