Ask Your Question

Writer: get the Navigator to show all heading levels

asked 2020-06-14 15:17:38 +0100

whinberry gravatar image

In a Writer document, when I click on 'Headings' in the Navigator it only shows the Heading 1s. The only way I can get it to show all the heading levels is to go down the list clicking the little black triangle on each one, which takes ages. I've tried altering in the 'Heading Levels Shown' box but that has no effect at all, whatever I do to it. Surely there must be a quick way of getting the Navigator to show all levels? Anybody?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2020-06-14 19:00:26 +0100

torreone gravatar image

In my version ( work simple click on heading (or in every subtree) and after CTRL + (key Control and Key plus)

edit flag offensive delete link more


Thank you! I've been trying to work that out all evening with no result. I even deleted LibreOffice from my laptop and reinstalled with version, only to find the same problem. And then I decided to upgrade from Ubuntu 18.04 to 20.04 while I was at it. And still had the same problem. What baffles me, though, is what the 'Headings Level Shown' box is for.

whinberry gravatar imagewhinberry ( 2020-06-15 00:43:01 +0100 )edit

You can limit the TOC to some level, e.g. you structure your document with Heading 1 to Heading 6 but only levels 1 to 3 are entered into the TOC, levels 4 to 6 being some sort of numbered list deemed not important enough for the TOC. This setting is in the dialog for creating the TOC. In case you want the Navigator to match your TOC, you select level 3 in Headings Level Shown. After that, an Expand All will instantly display an equivalent of your TOC.

ajlittoz gravatar imageajlittoz ( 2020-06-15 07:55:04 +0100 )edit

@whinberry thank to you!

Question for everyone: the navigator allows you to move the headings with all the associated text. By working with the cursors you can create a macro that performs the same function. But the navigator evidently accesses an API that does this. Is there any way to access this API from star basic?

torreone gravatar imagetorreone ( 2020-06-15 22:00:07 +0100 )edit

answered 2020-06-14 15:38:51 +0100

ajlittoz gravatar image

In the Navigator, right-click on Headings and Expand All.

The same on any heading, only expands the sub-headings under this heading.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer) or comment the relevant answer.

edit flag offensive delete link more


If I right-click on Headings I don't get an Expand All option. I get the options 'Outline Level', 'Drag Mode' and 'Display'. Outline Level leads to a number box, but clicking any of the numbers does nothing.

whinberry gravatar imagewhinberry ( 2020-06-14 15:47:44 +0100 )edit

Then what is your LO version?

Outline Level only limits the depth of expansion for Expand All. Per se, it does nothing.

ajlittoz gravatar imageajlittoz ( 2020-06-14 15:59:26 +0100 )edit

My version is

whinberry gravatar imagewhinberry ( 2020-06-14 16:41:09 +0100 )edit

Ah. Partial light dawns. I've just tried my documents on another computer which has a later LO and everything works perfectly. I shall update LO on the laptop where I'm having the trouble.

whinberry gravatar imagewhinberry ( 2020-06-14 16:52:40 +0100 )edit

I suspected a version issue.

ajlittoz gravatar imageajlittoz ( 2020-06-14 17:08:36 +0100 )edit

On that comment I made about partial light dawning. On that other computer where it could be done, I stopped being able to do it after some software updates a couple of hours ago. Now I have to do torreone's Ctrl + thing on that machine, too. All very odd ...

whinberry gravatar imagewhinberry ( 2020-06-15 00:52:24 +0100 )edit

Ctrl + * can be used which will Expand All or Collapse All depending on the current state. Ctrl + Shift + 8 = Ctrl + * on my keyboard.

Jim Raykowski gravatar imageJim Raykowski ( 2020-06-21 02:49:12 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-06-14 15:17:38 +0100

Seen: 163 times

Last updated: Jun 14 '20