Ask Your Question
0

major formatting problems in Writer on Ubuntu Linux

asked 2020-06-18 04:39:08 +0200

guanolto gravatar image

updated 2020-06-18 08:10:12 +0200

ajlittoz gravatar image

I’m having several big problems with formatting in Writer. I’m grouping them all together here because they all seem pretty similar, which makes me think they’re closely related. All of this is with files in OpenDocument format, and in Ubuntu Linux 18.04, except as otherwise noted. I’ve searched online numerous times but have not found anyone discussing these same formatting issues. I don’t remember what website is used for submitting and following bug reports for LO, so I haven’t searched those reports.

(#1: Numbered Items and Indentation are Broken) A month or two ago I was trying to write a contract, and the numbered items could not indent normally or keep normal formatting. I could not get normal, non-indented numbering like 1., 2., 3., with indented subpoints like A., B., C., etc. The more I tried to fix the problems, the more bizarre the formatting became, I think with italics and increasingly unusual indentation. I tried copying and pasting the document’s full contents without formatting into a new blank file, but the after I started recreating the formatting, the same problems recurred like in the original document. I struggled with this for more than an hour and finally switched to using Google Docs for the contract, which worked easily and normally once I learned how to use the Google Docs indentation features. (I no longer have the original documents nor the precise details for this problem. I’m just including this here on the list in case it helps shed some light on the other problems.)

In the meantime, I attempted to upgrade Ubuntu to 20.04, but had to reinstall 18.04 because the newer Ubuntu uses a version of the Linux kernel that does not allow installing a Displaylink driver for my Asus external monitor, and the extra screen space is essential for my work. So after a fresh reinstall of Ubuntu 18.04, some weeks later I ran into problems #2 and #3:

#2: Boldface Is Not Available Without Italics I have a file that includes some bold and italic formatting. Last week I opened it up to use it as a template for a new, similar file. Then I noticed that items that were in bold were also italicized. I looked around and found that this was true in every case: Whenever I put any text in bold, it also became italicized. The toolbar indicated that the text was only bold and not italicized, contrary to what I was actually seeing on the page. On the next day I tried to copy the text into a new file without formatting, and when I started redoing formatting I was able to bold and italicize text normally, in the same font as before. I decided to upgrade LO (from v6.0 to v6.4.4.2), so did this by adding the special repository, updating, and installing LO in Terminal. (I know this is not recommended ― LibreOffice version 6.0 ... (plus)

edit retag flag offensive close merge delete

Comments

I uploaded two screenshots. The link that I see here displays the second of them, and there is some additional path after it that must be the other screenshot, but I don't know how to view it from the link.

guanolto gravatar imageguanolto ( 2020-06-18 04:41:37 +0200 )edit

The trick is to separate the links by empty lines so that they don't interfere.

ajlittoz gravatar imageajlittoz ( 2020-06-18 08:12:25 +0200 )edit

I had considered this problem resolved, but today I’m seeing a proliferation of #3, the shunken-text problem, in other files in Writer and now also in Calc.

Here is a screenshot of the problem in my recipe collection, where I tried to type a new recipe today. Everything new that I typed was really small, even though the control bar showed normal font sizes. First I tried typing the title, at 18 points and bold and underlined, and it was really small. (This is an already existing file and I have not set it up yet to use styles.) Remembering that the problem happened with several fonts when I tested last time, including Gentium, I decided to change the whole file from Gentium to Garamond. This allowed me to type the title at normal size. Then when I tried to type the recipe itself, I got tiny text in ...(plus)

guanolto gravatar imageguanolto ( 2020-06-28 22:21:14 +0200 )edit

Earlier today I started typing in a cell in a Calc spreadsheet, and there too I got tiny text. It was in the Gentium font. Just now I tried to reproduce the problem there in order to get a screenshot, but the problem did not happen.

This shrinking-text problem is not happening everywhere. Most files are still working normally when I open them up and start typing. But I saw this problem earlier in my novel [1 Flights of a Sparrow.odt], I see it today in my recipe collection [Scott's Great Recipes.odt], and this morning I saw it in a spreadsheet file [tu matrix.ods]. Right now when I open the novel and the spreadsheet file, the problem is not happening at all and I cannot reproduce it.

guanolto gravatar imageguanolto ( 2020-06-28 22:22:11 +0200 )edit

So again, this is in LibreOffice v6.4.4.2 running on Ubuntu Linux 18.04, which I reinstalled last month. And a week or two ago I upgraded from the OS’s default version, which was LibreOffice v6.0. As mentioned, I observed this problem with some fonts but not others: Text shrank with Gentium, Verdana, Humanist, Liberation Sans, Deja Vu Serif, and Goudy OldStyle, but not with FreeSerif, CenturyOld, Garamond, Calibri, Linux Biolinum, Liberation Serif, Maiandra, Open Sans, or Ubuntu. But today I’m seeing it persist in my recipe file even when I switch to fonts that were okay last week.

guanolto gravatar imageguanolto ( 2020-06-28 22:24:37 +0200 )edit

Trick to insert a screenshot in a comment: edit your answer (or create one) and add a picture, copy the markup code and paste it into the comment. Cancel the edited answer.

Since you problem seems to occur non-deterministically, I'd suspect a cause external to LO. To make sure, create a new user (account) in the same group as your current user. Set the permissions so that group has write access. From a terminal, copy (cp command line) one problematic file into the home directory of the new user. Quit your current session (ideally reboot to make sure no current configuration remain in effect). Log in with the new fresh user. See if the problem still occurs.

ajlittoz gravatar imageajlittoz ( 2020-06-29 07:54:09 +0200 )edit

Inserting the screenshot worked, but then it disappeared after a few minutes. I'm guessing that the website automatically removes comments with only a link but no text. I'll try adding it to this comment afterwards.

I created a new user account on my system, tempguest. I used the settings GUI and didn't have options for user privileges or determining user groups. But I think it worked fine using defaults.

I was not able to copy the file with the cp command (somehow it hung up and didn't give me a new command line with my username prompt. So in Terminal I instead said nautilus admin:// and copied it in the file browser. I rebooted and logged in as the new user. The file was not available with full privileges but I could open and edit, and save it with a new name if I wanted.

The ...(plus)

guanolto gravatar imageguanolto ( 2020-06-29 20:50:53 +0200 )edit

Okay, now my screenshot-only comment has reappeared above.

Anyway, whenever I tried to add a new line of text in the same miniaturized paragraph, the new line was normal size but as soon as I started typing text, it became tiny too. Both in the new user account and in the regular one.

guanolto gravatar imageguanolto ( 2020-06-29 20:53:09 +0200 )edit

Is there any way to fix this problem? Currently I'm seeing this problem in several different files, and the workaround of switching to a different font isn't helping any more. This is really frustrating, because I have to keep selecting text and saying "Clear direct formatting," over and over again. I want to spend my time writing, not fiddling constantly with formatting. Or is there at least a useful workaround?

Just now I tried zooming in close so that I can read the miniature text more easily, but it's too hard to work with because I can't select specific text or see where I am when jumping forward word by word with CTRL-arrow.

guanolto gravatar imageguanolto ( 2020-07-11 06:08:55 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-06-19 02:46:19 +0200

guanolto gravatar image

updated 2020-06-19 02:47:37 +0200

Hi Ajlittoz, [I'm putting this in the solutions section because it's too big to fit as a comment.]

Thank you very much for your detailed reply. This seems to resolve problems #1 and #4. I’ll copy your advice for future reference.

I didn’t realize that showing formatting marks would be helpful. I’ll put new screenshots of those up.

You’re right: I hardly use styles. I went through a phase of using them a few years ago but drifted away from them because I felt like they were not providing a clear benefit. But I suppose they could save time with a large document or with anything that I’m standardizing. Currently I’m using styles in my novel only for setting chapter headings (so that I can use a hyperlinking table of contents to navigate around easily). I'll start using them more now, and review the instructions to remember the details of their use.

1. Indentation in Numbered Lists

Yes, that’s right: I started the numbering by turning it on with the toolbar button. I was mainly trying to edit the numbered points using Format > Bullets & Numbering, but I think I was also fiddling with the ruler now and then, so maybe that caused all the problems. I just tried copying some numbered text from my contract into a new blank file, and now I’m able to get the desired behavior:

C:\fakepath\numbered lists 2020-06-18.png

Now I was able to demote numbered items, and I also stumbled into Context Menu > Bullets and Numbering > Alphabet Lowercase List. I hadn’t seen that before, so maybe it’s a new feature after v6.0. Thanks for the shortcut tip with demoting items ― that’s the same as in Google Docs, so that’ll be easy to remember. All I would need beyond this point is just to add spacing above and below paragraphs. Yes, it looks like I’d want to create styles for the different paragraph types so that I can get them again. Google Docs was able to handle that automatically just with setting numbering and demoting/promoting, but probably only because it’s not as full-featured and complex as LO Writer.

Based on all that, it looks like problem #1 is resolved.

2. Boldface with Unintentional Italics

Yes, you’re right, I’m referring to ~/.fonts ― I can create such a folder to make my favorite fonts available on the system. Fonts that are installed automatically by software are located at /usr/share/fonts. At first I thought it could be a font issue. I checked to be sure all the font variants were there, and then checked that there are no duplicate or nearly-identical ones in the system font folder just mentioned.

So, here is the file:

C:\fakepath\syllable stress rule sample.odt

In this file, the problem is still occurring in this one-page sample file, and in fresh new files too ... (plus)

edit flag offensive delete link more

Comments

#2 Boldface w/ italics

Open Sans is not installed. It is substituted by some local font. I tried on two different computers and it displays without italics.

#3 Shrinken text

Font Jessica Serial missing on my computer(s). When I add text anywhere, it comes standard size. Try to replace the sample file with one already exhibiting the glitch. Does it happen with another font?

ajlittoz gravatar imageajlittoz ( 2020-06-19 09:24:09 +0200 )edit

I’m thinking now that problems #2 and #3 are both font issues. I can avoid these problems by choosing other fonts, as a workaround. But I don’t understand why these fonts started behaving strangely. As far as I can tell it is specific to LibreOffice: Today I tested using Open Sans and Jessica Serial in another program, OmegaT, and did not see any of the strange behavior with bold text or typing new text.

guanolto gravatar imageguanolto ( 2020-06-19 23:21:05 +0200 )edit

2. Boldface with Unintentional Italics

When you say “Open Sans is not installed,” I’m assuming that you mean on your computer (just as you mentioned regarding #3). I’ve always found that adding a font works fine if I just drop and drop new font files into ~/.fonts and restarting LibreOffice. Checking again in the same document today, I’ve tried switching to other fonts, and I don’t see this problem repeating with any other font. (I chose Open Sans in order to stay consistent with the font I use on my website. I looked carefully at the text in the document today and it does seem to match the appearance of the text on my website.) It looks like my solution should be to either switch the document’s font to Humanist or to Montreal Serial, or to apply Open Sans Semibold for headings, though the headings ...(plus)

guanolto gravatar imageguanolto ( 2020-06-19 23:21:31 +0200 )edit

3. Shrunken Text in Paragraphs

I tried changing a paragraph to other fonts to see whether this problem persists. The text shrank the same as before with Gentium, Verdana, Humanist, Liberation Sans, Deja Vu Serif, and Goudy OldStyle. It continues to shrink only when I type at the end of the paragraph and not in the middle. But the text did not shrink with FreeSerif, CenturyOld, Garamond, Calibri, Linux Biolinum, Liberation Serif, Maiandra, Open Sans, or Ubuntu. I checked a second time with some of these and the results corresponded to the first round of tests.

guanolto gravatar imageguanolto ( 2020-06-19 23:21:49 +0200 )edit

I basically have workarounds here that will work, just by changing to other fonts. So feel free to let this go if you don’t have any other ideas. Thanks again for your advice. These problems have been really aggravating for me, and you’ve been a great help. I will definitely start using styles again ― their best advantage of all may be the ease and speed of switching an entire document from one font to another.

guanolto gravatar imageguanolto ( 2020-06-19 23:22:03 +0200 )edit
0

answered 2020-06-18 09:01:03 +0200

ajlittoz gravatar image

I think most of your problems come from your workflow. Your screenshots were taken without enabling View>Formatting Marks to see exactly what's in your typing.

Your screenshots and the mention of Format>Clear Direct Formatting suggests that you manual format everything instead of consistently and systematically using styles. This also explains why reformatting a document takes hours instead of very few minutes with styles.

1. Indentation in numbered lists

I assume that your numbered list is created by using the button in the toolbar which transforms an ordinary paragraph in a numbered item.

When you do this, don't play with the ruler anymore because the paragraph is now controlled by Format>Bullets & Numbering. Indents and level-dependent characteristics are tuned in the Position and Customize tabs. Once you begin to play with the settings there, never use again the other tabs because they will force reset of some attributes you painfully tuned.

Levels in the numbered items are set by Tab or Shift+Tab at the beginning of the item. Pressed in any other location, they behave as ordinary Tab.

The best you could do would be to customise one of built-in Numbering n paragraph styles so that you just style your items without caring for anything else. But this is a bit difficult for a newbie in style-lore.

2. Boldface with unintentional italics

I'd suspect some issue with fonts but you seem to rule out it. I don't understand the point about the font locations (isn't /.fonts rather ~/.fonts?) because handling them is different in my Fedora Linux and font installation (system-wide or user-only) is done through a utility in the configuration control center which takes care of all the details.

Since your paragraph is also blue, this implies you also played with the attributes (manual formatting again?). The best way to diagnose the issue would be an attachment of a one page sample file (to do that, edit your question and use the paper clip tool -- make sure to separate the link from the rest of the question with empty lines).

3. Shrinked paragraphs

I can't tell from the screenshot because of the missing View>Formatting Marks. I'd bet all your paragraphs end with a space character before the paragraph mark. This space character could have different attributes. The screenshot does not help much because the cursor is at end and not inside the smaller text. The image may hint that the last period (?) is not the same size as preceding text, size which is then reflected in the toolbar. Once again, a one-page sample file would definitely help.

4. Bullet point

A bullet or number in a list item is usually followed by a tab character (which is shown by View>Formatting Marks). If you try to change indent through the ruler, you'll break everything (see point 1. for the "standard" procedure). What happens is you don't leave enough space for the ... (more)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-06-18 04:39:08 +0200

Seen: 77 times

Last updated: Jun 19