macOS: unwanted document zoom when scrolling

asked 2020-06-23 10:10:26 +0200

I am aware that this question has already been discussed here, but it was falsely closed as "solved". So I'll go for another try.

When using Writer or another LibreOffice application, I regularly use my trackpad for scrolling. I also make heavy use of keyboard shortcuts. But when scrolling and the Cmd key are combined, my document is zoomed which is not what I want.

This even happens when smooth scrolling continues to decelerate after I lift my fingers off the trackpad, so I have to pause for a moment until the scrolling is completed. This is very contradictory to my "muscle memory" workflow.

To be clear, this behaviour is NOT referencing the screen loupe (zoom) macOS has built in (to be activated in System Preferences → Accessibiliy → Zoom → Use scroll gestures with modifier keys to zoom. That function is bound to the Ctrl key on my system and poses no problems. I am speaking about the LibreOffice function that is also accessible under the View → Zoom menu that only changes the document's zoom level.

So, is there a way to solve this? Maybe disable scroll-based zooming in LibreOffice altogether? I am perfectly fine with all the other ways to zoom my document (menu, slider at the bottom right, trackpad pinch gesture). Any other suggestions?

Thank you.

edit retag flag offensive close merge delete