Ask Your Question
0

Can you change the font and size of text in drop down lists? [closed]

asked 2020-07-11 16:21:13 +0100

Steve R. gravatar image

updated 2020-11-26 22:38:04 +0100

Alex Kemp gravatar image

The drop down lists in the toolbars contain fonts that are: (for me too) too small and lack contrast with the background (grey on grey). See sample image below.

Currently using Mint 19.3 with LibreOffice 6.4.4.2 I'm also using a high definition monitor where the display resolution is 3848x2160. I am using the cinnamon desktop.

I also notice that on one computer, the grey background is missing. A good thing.

How can the grey background in the drop down list shown below be eliminated? A preferred choice.

How can the size of the fonts be increased and perhaps be made bolder for added contrast?

image description

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-11-26 22:38:13.723445

Comments

I suspect the solution is not in LO itself. These are UI elements controlled by GTK+ (at least under the usual Mint desktop manager. There is a CSS sheet hidden somewhere to customise all UI aspects.

Before delving into the CSS, you can try varying the desktop theme. The "control center" or "configuration manager" generally offers limited ways to alter some aspect of the UI. Have a try there.

ajlittoz gravatar imageajlittoz ( 2020-07-11 16:34:24 +0100 )edit

In following up on your comments, I have modified the question above a bit. Under the Mint Menu drop down list, I found what appear to be two relevant apps; fonts and tweaks. Changes to these two apps did not seem to make a difference. Under Mint 19.3, I do not see either "control center" or "configuration manager".

Steve R. gravatar imageSteve R. ( 2020-07-11 17:30:17 +0100 )edit

I'm using Fedora 32 with KDE Plasma desktop. It's quite difficult to extrapolate because Mint comes , I think, with Cinnamon desktop which is a derivative o GNOME. You have perhaps a theme manager. Try to see if changing the Mint theme has an impact of the LO menus. If yes, you'll have to find which utility configures the desktop appearance.

AFAIK, high definition screens come with a pitch finer than common monitors to avoid ending with HUGE sizes (as an example, a 4K monitor with "standard" pitch would be 46-50" wide). . The consequence is UI displays very small. This is addressed by the desktop configuration where you can increase menu and other UI elements font size.

ajlittoz gravatar imageajlittoz ( 2020-07-11 17:48:09 +0100 )edit

I looked at the themes between the two computers. Both looked identical. I also increased the font sizes which can be done either directly or through text scaling in the font application. Those changes did not have an effect. However, I notice, that with the computer that I am having Writer problems with, that the title bar (file, edit, view ...) itself seems smaller implying that configuring the title bar may have it "own" configuration source (of course that can simply be a reflection of the screen resolution).

Steve R. gravatar imageSteve R. ( 2020-07-11 18:19:45 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-07-11 18:00:51 +0100

Opaque gravatar image

updated 2020-07-11 18:12:28 +0100

Hello,

your screenshot looks like you are missing package libreoffice-gtk3 and hence you are using VCL:x11 (see Help -> About LibreOffice). Using command sudo apt install libreoffice-gtk3 -y should fix that (and show the font size of your display managers settings and make LibreOffice menu look like menus of other GTK3 based applications).

PS: Don't forget to restart LibreOffice after having installed package libreoffice-gtk3

Hope that helps.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2020-07-11 16:21:13 +0100

Seen: 154 times

Last updated: Jul 11 '20