Ask Your Question
0

xlsx and xlsb files in LibreOffice Calc

asked 2020-07-30 14:41:28 +0200

GKM gravatar image

When I open an xlsx or xlsb file in LibreOffice Calc I get a excess column warning. But this can't be as each sheet (about 36) have less than 50 columns each.

edit retag flag offensive close merge delete

Comments

I've seen this in excel sheets before. Not sure of the exact cause. I'm sure someone here can answer it better than myself. It seems to be how the sheet was originally created. Never had enough time at work to to really figure out why.

AdmFubar gravatar imageAdmFubar ( 2020-07-30 18:50:08 +0200 )edit

If a sheet is protected the protection is for the full extent of the sheet. Removing protection is likely to enable LO to open it.

As an aside, apparently Google sheets ignores protection and can open 17k or 18k columns in any event

Earnest Al gravatar imageEarnest Al ( 2020-07-31 00:49:48 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-07-30 18:45:50 +0200

Opaque gravatar image

updated 2020-07-30 18:46:27 +0200

Hello,

this is a common problem. Any character (even an invisible one) in any cell range outside of LibreOffice's limits (1024 cols) will cause that error. I'm pretty sure that there is content in your file beyond column AMJ. Thus you need to fix your original file using Excel for content beyond AMJ. Eventually you can use - for testing purposes - LibreOffice 7.0.0.2 (Release Candidate 2), which support 16k columns ( Tools -> Options -> LibreOffice -> Advanced -> [x] Enable experimental features (may be unstable) and Tools -> Options -> LibreOffice Calc -> Defaults -> [x] Enable very large spreadsheets (16m row, 16384 cols) enabled.

(Or you upload your file, so that someone could check, where you content causing the error is located)

Hope that helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-07-30 14:41:28 +0200

Seen: 22 times

Last updated: Jul 30