default page size for html import

asked 2020-09-16 14:46:26 +0200

I'm trying to use LibreOffice (6.4.5.2) in headless mode with the --convert-to option to convert HTML e-mails into PDF files. This works great for the most part, except for the page size.

If I do it in Windows, I get a Letter size PDF, which is what I want; in (gentoo) Linux, I get A4 size. I verified that my system locale settings on Linux are set to en_US, in fact the other locales for LibreOffice aren't even installed.

Where can I change the default? I'm hoping for a configuration file I can change since the Linux server does NOT have a desktop environment. I do have that option on my Windows PC, but that one doesn't have the issue. Nor can I seem to find a way to get it to start outputting A4 on the command line like my Linux server does to even start to figure out where that is stored.

I haven't actually changed any configuration settings on either one of them, this behavior is present on a fresh install. I did find a workaround that involves embedding @page CSS in the file, but I feel like I should be able to achieve this without doing that since it is behaving correctly on Windows.

edit retag flag offensive close merge delete