Ask Your Question
0

Can not open document with non-english characters in filename

asked 2020-09-21 12:18:59 +0100

TJRoh01 gravatar image

updated 2020-09-21 16:20:21 +0100

For example I have a file named "möbler.odt" (furniture in swedish) and when I try to open it LibreOffice Writer says: "/path/to/file/m??bler.odt does not exist."

If I replace the ö with an o it works. I have the swedish language pack installed (for the system and for LibreOffice). I am using Fedora KDE (Plasma version 5.18.5, LO Writer version 6.4.6).

Any help is very appreciated!

edit 1: filesystem is ext4 within LUKS; edit 2: removed writer tag since this affects all LO programs; edit 3: it only affects LO programs, everything else works fine; edit 4: edit version from Fedoras version to just the LO version;

edit retag flag offensive close merge delete

Comments

I have the same configuration (swedish pack excepted) and it works here. Which file system have you formatted your disks with? ext4 (or btrfs) have no problem with UTF-8 names but other file systems may be limited if they don't use Unicode.

PS:retag to remove either writer or common. I suspect this happens with all components (Calc, Impress, Writer, …) as I think it is OS-related. common covers all components and writer is redundant.

ajlittoz gravatar imageajlittoz ( 2020-09-21 12:31:26 +0100 )edit

I am using ext4 within LUKS

TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 12:32:29 +0100 )edit

Thanks for tip with tags :) Fixed it. It does affect all LO programs

TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 12:37:10 +0100 )edit

What's your locale?

gabix gravatar imagegabix ( 2020-09-21 13:08:35 +0100 )edit

My locale output looks like this:

  • LANG=en_US.UTF-8
  • LC_CTYPE="en_US.UTF-8"
  • LC_NUMERIC="en_US.UTF-8"
  • LC_TIME="en_US.UTF-8"
  • LC_COLLATE="en_US.UTF-8"
  • LC_MONETARY="en_US.UTF-8"
  • LC_MESSAGES="en_US.UTF-8"
  • LC_PAPER="en_US.UTF-8"
  • LC_NAME="en_US.UTF-8"
  • LC_ADDRESS="en_US.UTF-8"
  • LC_TELEPHONE="en_US.UTF-8"
  • LC_MEASUREMENT="en_US.UTF-8"
  • LC_IDENTIFICATION="en_US.UTF-8"
  • LC_ALL=
TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 13:09:51 +0100 )edit

Weird. The locale is fine. Does the problem appear when you try to open files from LibreOffice dialog or from you file manager?

gabix gravatar imagegabix ( 2020-09-21 13:20:26 +0100 )edit

It happens in both

TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 13:42:48 +0100 )edit

I don't know the format you give your LibreOffice version in. By what means did you get it?
There isn't a specific Writer version.
Can you confirm that your ö in the FileName actually is U+00F6 or U+00F8?
[Why did you use a German umlaut (French o with trema?) for a Swedish ø?]

Lupp gravatar imageLupp ( 2020-09-21 15:58:19 +0100 )edit

It was Fedoras version, fixed it. LO version is 6.4.6.

I think you got Swedish confused with Danish/Norwegian ;) It is without doubt U+00F6 ö and supposed to be so.

TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 16:22:54 +0100 )edit

Out of ideas. Just for clarity: is the file in question located on an ext4 partition or on an NTFS/FAT partition?

gabix gravatar imagegabix ( 2020-09-21 16:27:59 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-09-21 17:26:16 +0100

Lupp gravatar image

Not completely out of ideas nonetheless:
You got two question marks in your error message.
There are the (strange) combining characters in unicode: The trema U+0308 e.g. combines with the character left of it. A U+006F (lower o) with a subsequent U+0308 (trema) combines visually to an ö which would be coded U+00F6 otherwise.
If your actual FilePaths contain combining glyphs some applications may handle that and others may not.
On the other hand there reamains the question who (human or software) caused the issue.

edit flag offensive delete link more

Comments

Interesting. Well I have a dedicated ö key on my keyboard. Will test around with character codes.

TJRoh01 gravatar imageTJRoh01 ( 2020-09-21 17:30:59 +0100 )edit

Just tested with filenames containing the sequence U+006F, U+0308 on Win 10.
The OS accepts that.
LibO V 7.0.1 (64bit) and LibO V 6.4.4 (x64) both handle it, too.
The behaviour of the cursor going over a U+0308 is slightly different, though. Anyway the effects may depend on the OS.

My old general and serious advice:
Use only syntactically clean names for folders and files: No spaces or special characters at all, whether the system and other software pretend to accept them or not. No use in localization spilling over!
Unfortunately we cannot make undone the lots of pointless stubborn "extensions" to the latin alphabet invented over centuries. They simply are a plague.

Lupp gravatar imageLupp ( 2020-09-21 17:56:04 +0100 )edit

@Lupp wrote:
My old general and serious advice:
Use only syntactically clean names for folders and files: No spaces or special characters at all, whether the system and other software pretend to accept them or not. No use in localization spilling over!
+1

Grantler gravatar imageGrantler ( 2020-09-21 18:01:03 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-09-21 12:18:59 +0100

Seen: 84 times

Last updated: Sep 21