How to launch old LibreOffice in AppImage?

asked 2020-09-23 14:05:45 +0100

  • OS: Debian GNU/Linux Sid(amd64)
  • AppImage: LibreOffice-4.3.7.2.standard-x86_64.AppImage

I needed old LibreOffice and downloaded AppImage.

I set the execution permissions on AppImage and got the following error when I tried to launch it.

$ ./LibreOffice-4.3.7.2.standard-x86_64.AppImage 
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

OpenJDK is installed.

$ LANG=C dpkg-query -l *jre*
ii  default-jre                   2:1.11-72    amd64        Standard Java or Java compatible Runtime
ii  default-jre-headless          2:1.11-72    amd64        Standard Java or Java compatible Runtime (headless)
ii  openjdk-11-jre:amd64          11.0.8+10-1  amd64        OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-11-jre-headless:amd64 11.0.8+10-1  amd64        OpenJDK Java runtime, using Hotspot JIT (headless)
ii  openjdk-11-jre-zero:amd64     11.0.8+10-1  amd64        Alternative JVM for OpenJDK, using Zero
ii  openjdk-8-jre:amd64           8u265-b01-1  amd64        OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-8-jre-headless:amd64  8u265-b01-1  amd64        OpenJDK Java runtime, using Hotspot JIT (headless)

How can I launch LibreOffice AppImage?

edit retag flag offensive close merge delete

Comments

I think the problem could be glibc related ... but what do you get when exeucting

./LibreOffice-4.3.7.2.standard-x86_64.AppImage -h

Segfault or does the help ext get printed ?

igorlius gravatar imageigorlius ( 2020-09-23 14:43:32 +0100 )edit

If java is not needed a simple installation in parallel could do...

Grantler gravatar imageGrantler ( 2020-09-23 16:08:15 +0100 )edit

Segfault or does the help ext get printed ?

No segmentation fault and Help is displayed. here was no option to disable Java.

If java is not needed a simple installation in parallel could do...

Hmm... AppImage is can't be use?

nogajun gravatar imagenogajun ( 2020-09-25 07:08:45 +0100 )edit

I edited $HOME/.config/libreoffice/4.3.7.2/user/config/javasettings_Linux_X86_64.xml, but it did not start.

nogajun gravatar imagenogajun ( 2020-09-25 07:11:02 +0100 )edit

You could try extracting the AppImage and maybe executing the the bins directly. At least mabe you will get a more meaningful error

./LibreOffice-4.3.7.2.standard-x86_64.AppImage  --appimage-extract

That should create a folder squashfs-root, in which you will find the AppImage content.

the bins are located under squashfs/opt/

igorlius gravatar imageigorlius ( 2020-09-25 15:07:23 +0100 )edit