mailmerge function

asked 2020-09-25 12:19:08 +0200

zafeiros gravatar image

updated 2020-09-25 13:36:05 +0200

Using the current version windows64bit (7.0.1.2). Trying to use mailmerge function. I have encountered a serious problem. At the final stage where the documents are sent at the mail recipients, it skips a recipient email!! thus sending all personalised messages to wrong recipients. I started over with new files and all seemed to work perfectly, until later that day where again the same problem appeared!! It is very frustrating because i cannot find why it happpened. If anyone has any idea i would be gratefull

If this is not sorted out this tool cannot be considered reliable for serious work.

regards

Alex

edit retag flag offensive close merge delete

Comments

while looking found earlier similar questions with no answear.

zafeiros gravatar imagezafeiros ( 2020-09-25 13:37:23 +0200 )edit

Did you check that all your email addresses are valid? No records with empty email, spaces in address, or missing top level domain? (If this causes misalignment of address with personalized data, it is most likely a bug and should be reported.)

Do you use the Writer/Base connection all the way (single pass) or do you prepare documents first, then send them in a different process?

Do you have conditional content in your message template? Perhaps a stray next record field in there?

keme gravatar imagekeme ( 2020-09-25 17:05:11 +0200 )edit

All my addresses were valid. In fact the same calc file was used with a new writer file and mail merge worked fine for a while. I use the writer/calc connection all the way. I have no conditional content. In fact copy and paste of the total content to a new writer file made it work for a while.

Thanks for the reply. Where do I report bugs.?

Iwe are a university public lab. I have to prepare 2000 covid reports and mail them every day. I have to be sure the correct person gets the correct result otherwise hell will break loose.

zafeiros gravatar imagezafeiros ( 2020-09-25 17:32:29 +0200 )edit

Can you attach the merge message file to your question? (Edit your question and use the paperclip tool to upload an attachment.) That file should not hold any confidential information (everything would be fetched from the data source, which of course you don't submit).

What version of LibreOffice are you using? (Help - About)

A spreadsheet is not very reliable when it comes to data integrity. Are there merged cells in your data source? In any case, a proper database (even using the embedded database service in LibreOffice) is better suited to this kind of task than Calc.

Bugs should be reported here. Preferably one report per bug, and with a method and/or set of files which can reliably reproduce the error it causes.

keme gravatar imagekeme ( 2020-09-25 18:20:02 +0200 )edit