We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How do you use the default template when importing a .tsv?

asked 2020-10-01 18:03:13 +0200

smurf gravatar image

In LibreOffice Calc (Mac, 7.0.0.3), I've created my own default template. If I create a new spreadsheet, it uses my default template as a base, so I know that much is working. But if I open a .tsv, it doesn't use my default template. (For example, the converted .tsv uses the Liberation Sans font instead of the font in my default template.)

How do I make LibreOffice respect my default template when converting a .tsv?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2020-10-01 19:44:02 +0200

Opaque gravatar image

updated 2020-10-01 22:51:43 +0200

Hello,

as far as I understand bug report #tdf86336 -FILEOPEN Calc ignores custom template when opening csv file (.tsv is a special variant of .csv) this is intended behavior.

So the answer to your question "How do I make LibreOffice respect my default template when converting a .tsv? finally is: Not at all automatically. You need to format your import afterwards.

Sorry for the negative answer.

edit flag offensive delete link more
1

answered 2020-10-01 19:46:45 +0200

erAck gravatar image

updated 2020-10-01 19:50:50 +0200

The difference is that opening any file, regardless of type, is not creating a new document, hence the default template is not used. You can create a template or document with an explicit cell style with the desired attribution (do not use the default cell style for this but a new named style instead) and assign that style to one cell, and after having opened a .tsv file copy&paste that one cell to the opened document, which also pastes the style along, after which you can select the imported data or entire sheet and apply the pasted style.

Or simply open a new document from your default template and use Sheet -> Insert Sheet from File... to insert the .tsv

edit flag offensive delete link more
0

answered 2020-10-02 17:20:29 +0200

smurf gravatar image

Just as a followup for others' reference, I was able to work around just the font part of the problem. In Options/LibreOffice/Fonts, I added font substitution, replacing Liberation Sans with my chosen font. Now the font is correct, at least, when I import a .tsv. That doesn't answer any other parts of my default template of course (font size, freezing the top row, etc.) but it's one step closer, anyway.

New document, then Insert Sheet from File does not work around this... when the .tsv gets inserted, it overwrites whatever was there before, including any formatting. (And for that matter, including any data!) The only difference from doing that way is the name of the document.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-01 18:03:13 +0200

Seen: 119 times

Last updated: Oct 02 '20