Ask Your Question
0

Looking to add Chapter "number" translated to Portuguese

asked 2020-10-16 23:53:56 +0100

JUSTROB gravatar image

I see I can add chapter and numbering at the head of each chapter by using Tools>Chapter Numbering.

I'm translating a document into Portuguese and would like to set up the chapter numbering so that: Paragraph style will be the Heading I'm using Number set to "One, Two, Three, ..." However I'd like to have the Portuguese translation.

Is there a way to do that?

Also, when I try to add that it get's put in the header even though I want it in the Body text. What am I doing wrong? See photo of where I'd like it (at the top of the page):

image description

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-10-17 08:33:08 +0100

ajlittoz gravatar image

To get numbering type "One, Two, Three" in Portuguese, set the language of your text to Portuguese. The simplest way to do that is to modify paragraph style Default Style. In Font tab, set language to Portuguese (you can choose among several national variants). Changing it in Default Style will propagate to all other styles.

Your screenshot shows the following outline:

  • "CAPITULO UM" styled Chapter Name derived from Heading 2

    This means Chapter Name inherits the properties of Heading 2 to allow overrides without modifying Heading 2. Except that the outline level in not inherited, meaning the paragraph is considered body text by LO, not a heading, unless you assign an outline level to your Chapter Name.

  • a separate paragraph "SURPREENDIDO ..." in a different unspecified paragraph style.

With such a structure (assuming Chapter Name is assigned outline level 2 as suggested by its derivation), the heading consists only of "CAPITULO x" because their "number" is separate from the real title, the next paragraph. To get your expected layout, the number and the heading must be in the same paragraph. You have then two solutions:

  • replace the paragraph mark (Enter) by a line break (Shift+Enter) and set a specific character style on the "number" for reduced size

  • remove altogether the manual number to use automatic numbering set by Tools>Chapter Numbering; this number can be followed by a linebreak instead of the usual space or tab

When you echo the chapter heading in the header with fields, the first solution will display complete text because LO can't make a difference between words intended for a manual number and words for the title. In the second solution, the number is internally generated and therefore known to be a number, which allows you to select either the full paragraph content, the number only or the heading without the number.

If your present "CAPITULO x" is manually typed (and styled Heading n), it is considered an unnumbered heading and will be echoed in the header as the heading-without-number. Surprising but logical.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Ok, I have the chapters under Heading 2 and working with Tools>Chapter Numbering and they are working perfectly and translating to Portuguese.

My problem with the Chapter x paragraph is that it doesn't look centered even though the alignment is set to center. As a check I changed it to Left Align and it jumped far left of my page margin to the edge of the page. I can't find anything that will correct that.

Before I made the chapter Heading 2 changes I had the section name paragraphs as Heading 1 and on every right page I had Chapter Page Number in the header and it was working. Now the section name paragraphs (set as Heading 1) are not showing in the right page headers. All I'm getting are the page numbers. I have the headers set with two fields: Chapter Page Number. It was working ...(more)

JUSTROB gravatar imageJUSTROB ( 2020-10-17 23:31:49 +0100 )edit

Centering problem: Heading 2 alignment mode interferes with Tools>Chapter Numbering, Position tab settings. This is inevitable but allows very sophisticated layouts.

In your case, set Heading 2 to center alignment (but check your indents are "normal" at 0 otherwise you could start in the margins or offset). In Tools>Chapter Numbering, Position tab for level 2, set Numbering alignment to Left with Aligned at0. If you're offset, the number will not be centered.

ajlittoz gravatar imageajlittoz ( 2020-10-18 09:41:50 +0100 )edit

That fixed the centering problem. Thank you!

I am still having a problem though with the right page header not showing the Section Name or section subject. I have each Section Name paragraph as Heading 1. Then in the right page header I have 2 fields: chapter page number

When I add the chapter field I click on insert > field then I clicked on More. Then I will select Chapter as the type And Chapter Name as the format.

This was working where the right page header would show the Section Name (Heading 1) followed by the page number. But now with the chapter numbering working for some reason the right page header only shows the page number. And I cannot get Heading 1 (Section Name) to show before the page number.

JUSTROB gravatar imageJUSTROB ( 2020-10-18 10:59:25 +0100 )edit

Since this is a rather document-specific issue than a general-interest question, contact me on my private mail.

ajlittoz gravatar imageajlittoz ( 2020-10-18 11:09:01 +0100 )edit

Message has been sent

JUSTROB gravatar imageJUSTROB ( 2020-10-18 11:21:49 +0100 )edit

Just sent two more replies to your emails, one with document and one without

JUSTROB gravatar imageJUSTROB ( 2020-10-18 17:07:17 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-10-16 23:53:56 +0100

Seen: 18 times

Last updated: Oct 17