Ask Your Question
1

How do I disable Libre Office from capitalizing the start of a word?

asked 2020-11-08 03:48:25 +0100

Mister Badger gravatar image

updated 2020-11-08 03:50:54 +0100

I have always had auto-correct un-ticked because I know what I'm typing and do not need assistance. How ever, for the first time I have now encountered an issue where typing a name (e.g. Esther Duryngton ) it would then capitalize the next word (e.g. Always). Now, having un-ticked every box in the autocorrect list, I see that I am able to type the word 'always' with a lower-case A, but in testing the name, and trying to type 'Duryngton' with a lower case 'd' it is not letting me and automatically makes it a capital D. I have no clue why it is doing this when I have autocorrect turned off or why the word processor would limit my ability to choose for myself. Any assistance is very much appreciated. Thank you for reading.

Note: I also noticed when copying 'Esther duryngton ' from my word processor to here, it copies the 'd' as lower case, even though it is upper case in the document. Very strange!

Edit: testing on another line of the text, the original issue remains, but only on certain lines.

edit retag flag offensive close merge delete

Comments

Did you type "Esther Duryngton" or did you copy it from another document? If I type Esther duryngton into Writer, then right-click on duryngton and select Character > Character > Font Effects > Effects > Case, and choose Title then duryngton is capitalised in appearance only. If I copy that and paste it into this comment it pastes as all lower-case. I can also select it in Writer and press Ctrl+M to remove direct formatting and it reverts to all lower-case.

If you need to change the capitalisation use the menu Format > Text > and choose the appropriate one, it will be a correct capital.

I use autocorrect, I know what I'm typing but sometimes my fingers donn't. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-11-08 07:05:11 +0100 )edit
1

Beware that Format>Text adds direct formatting and you will lose more and more control over your text. To know what's exactly in the text, use styles: paragraph for global paragraph formatting, character to override over words.

ajlittoz gravatar imageajlittoz ( 2020-11-08 07:58:20 +0100 )edit

@ajlittoz are you absolutely sure? We are talking about capitalisation, Format > Text > Capitalise Every Word is a replacement of the lower-case letters. You cannot change it by Ctrl+M.

Earnest Al gravatar imageEarnest Al ( 2020-11-08 10:15:35 +0100 )edit
1

@Earnest Al: you're partly right and I'm partly right. I checked. This is one of the evil features introduced in recent releases (under pressure of Word aficionados?). Backstage "macros" take over and modify your text without telling you what's happening (see e.g. the so-called "table styles").

Your text is changed by this group of commands outside style. Then Ctrl+M will do nothing.

Now considering title formatting is culture- or country-related, should this formatting be hard-typed or controlled by a style? There are pros and cons. I'm rather inclined for the style solution because it offers more versatility to proof-reviewers.

ajlittoz gravatar imageajlittoz ( 2020-11-08 10:29:31 +0100 )edit

I did copy it from fantasynamegenerators.com but I didn't expect that to make every word written after the name start with a capitalized letter. That's just silly!

Format>taxt>make lowercase doesn't affect these uppercase letters for me.

Mister Badger gravatar imageMister Badger ( 2020-11-09 22:39:36 +0100 )edit

That is because the text is already all lower case, just formatted to pretend to be title case.

Earnest Al gravatar imageEarnest Al ( 2020-11-09 23:21:51 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-11-08 21:59:17 +0100

Earnest Al gravatar image

@ajlittoz 's comment inclines me to think that your need to alter the character style to remove Title Case from it. Open the Styles sidebar (F11) and click on the Character style icon (normally second on the left with a stylised A). Click on the word Duryngton, and see which style is highlighted, right-click on that style and select Modify...

Modify character style

A dialog named Character Style: [style name] will appear, click on the tab Font Effects, under Effects > Case change the drop-down to (Without) and OK out

Change Case to (Without)

Formatting changes should be done by Styles but this is a data change so should be done by keyboard or macro replacement. As far as I am concerned the Title Case style is only for database front end to hide poorly entered data. Cheers, Al

edit flag offensive delete link more

Comments

Hi thanks for your reply. When selecting the word (double clicking to highlight it), it doesn't highlight any character style. It says on what ever character style I have highlighted (initially it was Default, which cannot be modified through right clicking it).

Mister Badger gravatar imageMister Badger ( 2020-11-09 22:40:52 +0100 )edit

In that case, just select the word, or the text, and press Ctrl+M to remove the direct formatting. Note that this will remove all direct formatting in your selection including any that you have added, e.g. Bold, Underline, colour, etc. Cheers, Al

Earnest Al gravatar imageEarnest Al ( 2020-11-09 23:17:59 +0100 )edit

@Ernest Al thank you very much for your help. God bless and have a great day :)

Mister Badger gravatar imageMister Badger ( 2020-11-10 01:20:34 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-11-08 03:48:25 +0100

Seen: 56 times

Last updated: Nov 08 '20