Ask Your Question
2

How to insert one-column-page in two-column document? [closed]

asked 2013-12-31 16:47:38 +0200

hansmex gravatar image

updated 2013-12-31 17:21:56 +0200

Hello all,

I have created a document with a two-column layout. Now I need to insert a few pages based on a one-column layout.

Problem is: I can't get rid of the two column layout.

I tried adding a Section and copying my text into it, but it's two columns all the same. I guess I must be doing something wrong.

Please help.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-05 18:18:13.746640

Comments

Looking forward to an answer to this one. I have a 2-col layout that I tried (and tried, and tried) to get a single column page into, but couldn't work it out. According to another Q&A, mixing column counts should be easy. Nothing in that thread seems to work -- if your layout is 2-columns to start with, anyway. Or maybe I'm just dim!!

David gravatar imageDavid ( 2013-12-31 19:55:22 +0200 )edit

I did it like this (not exactly what you were looking for bit it worked for me): Formar > Page > Columns = 1. Then I inserted a new Section and set the section to 2 columns (Insert > Section > Columns = 2. Then cut all of my 2-column text and pasted it into the 2-column section. The rest of the document remained at one column. Obviously the reverse would not work (you'd get a one colum section embedded into one of the two columns in the page).

Squirrel Murphy gravatar imageSquirrel Murphy ( 2014-03-12 21:51:33 +0200 )edit

@David, can you upload a redacted example (edit an answer, upload the file, copy the link, back out of the edit, and then use the same link in a comment), because the Insert > Section... method indicated in the linked answer is the usual method. Thanks.

oweng gravatar imageoweng ( 2014-08-09 15:03:53 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2014-10-29 11:59:22 +0200

Working with columns is a bit tricky. What I do is: define the pages styles: 1 with 3 columns and 1 with no columns. To apply you have to do a manual page break and in the options you will see that you can use a differnt page style. This, however, works only if you have different pages.

If you want to have multiple columns and a text in between with no columns the way I do it is: - type the multicolumn text - make a line break where you want to insert the no column text (or different number of columns text) - insert a section and the no column text in it

I hope that helps.

edit flag offensive delete link more
1

answered 2014-01-01 01:57:39 +0200

Regina gravatar image

updated 2014-01-01 22:03:27 +0200

I assume, that the two-columns are defined in the page style.

You need to define a page style with one-column. Then insert a manual page break by Insert > Manual Break, for example, and select this one-column page style there. After the one-column part you have to insert a manual page break again, and switch back to the two-column page style.

You might find it easier to work the other way round. Set the page style to one-column and put the two-column parts into sections.

edit flag offensive delete link more

Comments

@Regina - I tried exactly the steps you suggest, but with a 2-col layout, the manual break does not restrict the column number change across the break-boundary. :( I expect your suggestion (use a 1-col basic layout, and introduce 2-cols) is the only way forward at the moment.

David gravatar imageDavid ( 2014-01-01 11:50:36 +0200 )edit

Do you have defined a page style with one-column? You need to do. For example name it "single_column". Then select this style in the field "style" in the dialog for manual break.

Regina gravatar imageRegina ( 2014-01-01 13:45:01 +0200 )edit

@Regina : "Do you have defined a page style with one-column?" Yes, in fact. This is using "styles".

David gravatar imageDavid ( 2014-01-01 14:05:39 +0200 )edit
0

answered 2014-08-09 01:13:54 +0200

Howl gravatar image

updated 2014-08-09 01:18:55 +0200

I have a similar problem. I want to start as a one column and then change to a two column layout for a couple of pages. The frustrating thing is that whenever I apply any page style to a page it applies that style to the entire document. This happens across sections as well as across pages.

When you go to Format -> Columns you are going to change the column setting for the default page style. So when you change that all the pages change.

Also surprising is that I do not seem to be able to apply a custom page style to one page. At least for me, when I apply a page style to any page it applies it to every page in the document, even if there is a manual page break before that page or if pages are in a separate section.

The thing that worked for me was to leave the Default page style one column and make a custom Two_Column page style.

Where I want to shift to two columns I add a manual page break (Insert -> Manual Break) and in the style drop down choose my custom Two_Column style. When I want to go back I do the same thing and insert another manual page break with the Default style.

LibreOffice Version: 4.2.5.2

edit flag offensive delete link more
0

answered 2014-01-01 21:39:05 +0200

hansmex gravatar image

@Regina,

1 - My base-document is an auto-generated 200-page document, made by merging a template and a database. That template has two columns.

2 - Now I need to split this document into 14 or 15 sections, each section beginning with one or two one-column page(s).

Insert -> Manual break -> Style offers a short list of pre-defined styles, but none that I made myself. The list starts with Convert 1 thru 6, etc.

So, LibreOffice isn't capable of handling documents with variable column count? I can hardly believe I'm the first person who wants to do this. There MUST be some solution.

HELP!! :-)

edit flag offensive delete link more

Comments

@hansmex, if it does not work for you, then it might be, that your document does not use the page style to set the two columns but does something different. Double-click the page style field in the status bar (third from left, left of the language field). You get the page style dialog. How many columns has that style?

Having "Convert 1" in the list shows, that it is not original made by LO. But nevertheless your selfmade style should appear. Can you sent me the document?

Regina gravatar imageRegina ( 2014-01-01 22:01:09 +0200 )edit

How do I send you the file? I can't find your email address. Mine is hansdirkse@gmail.com.

hansmex gravatar imagehansmex ( 2014-01-02 01:14:18 +0200 )edit
Regina gravatar imageRegina ( 2014-10-29 16:49:04 +0200 )edit

You guys are, rather dumb. Never give your email like that. At least mask '@' with 'AT' or something.

rautamiekka gravatar imagerautamiekka ( 2014-10-29 16:53:46 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-12-31 16:47:38 +0200

Seen: 36,555 times

Last updated: Oct 29 '14