Ask Your Question
0

Footer format not preserved on Open in LibreOffice 4 [closed]

asked 2014-01-04 21:32:52 +0100

KevShane gravatar image

updated 2015-09-11 12:40:07 +0100

Alex Kemp gravatar image

With Writer in LibreOffice 4.0.6 I created a new blank document. I set the page to be a title page using Format, Title Page. Using a couple of manual page breaks I made 3 pages total. On the first page I added the footer text, "ONE". On the second page I deselected (not checked) "Same content left/right" using Format, Page, Footer, and I added the footer text, "TWO". On the third page I added the footer text, "THREE".

I saved the document and reopened it. The footers were "ONE", "THREE", and "THREE", even though "Same content left/right" is still shown as being deselected (not checked) for the 2nd and 3rd page (viewed using Format, Page, Footer).

I switched to a computer with LibreOffice 3.6.3 and it opened the document correctly! It showed footers "ONE", "TWO", and "THREE". So, LibreOffice 4.0.6 must have saved it properly.

How do I make the document open correctly in LibreOffice 4.0.6?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 06:54:32.630360

2 Answers

Sort by » oldest newest most voted
1

answered 2014-01-05 01:04:07 +0100

oweng gravatar image

I set the page to be a title page using Format, Title Page.

The defaults for this option will set the first page to use the First Page page style.

Using a couple of manual page breaks I made 3 pages total.

Use Insert > Manual Break... > Style of "Left Page" > click OK. This will set the second page to use the Left Page page style. Modify this page style to turn on the footer. Inserting a second manual page break on this new page will cause the third page to use the Right Page page style. Again, modify this page style to turn on the footer.

The footer content will now display as expected (separate first, left and right page content) and you can ignore all the first / left / right page options for footers.

edit flag offensive delete link more

Comments

1

Thank you! I had to update a 4 page brochure to do the same. I did not want to create a new document and copy the parts over. I used Format > Styles and Formatting > Page Styles and modified First Page, Left Page, and Right Page styles based on your info. Then I clicked into the 1st page and double-clicked the First Page style to apply. Similarly for left and right pages. Also, made 1st page Title Page with next page as page # 1. Reopened document and the left/right footer formatting was kept!

KevShane gravatar imageKevShane ( 2014-01-05 03:28:06 +0100 )edit
0

answered 2014-03-08 12:46:58 +0100

Ciobi gravatar image

The answer from @oweng is correct (you have to use different styles for left/right pages in order to open correctly in 4.0.6 ) but should have a bit more context. Normally you should be fine with using a single style and unchecking "Same content left/right". However, there is a bug that prevents this from working as expected, hence the different styles workaround. The bug seems to have been introduced in 4.0 and fixed in 4.2. There is a bug report for 4.1 at https://bugs.freedesktop.org/show_bug.cgi?id=74746

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-01-04 21:32:52 +0100

Seen: 258 times

Last updated: Mar 08 '14