unexpected shortcut key behavior

asked 2020-12-24 07:58:55 +0200

chiropterist gravatar image

Custom Character Style Shortcuts

I have defined custom character styles to use in documents written in both Latin and English. The purpose of these styles is to distinguish visually which language a portion of text is written in, and the keyboard shortcuts are meant to facilitate formatting the text while typing.

Here is the problem. Earlier today, the Latin shortcuts started inserting special characters instead of changing the character style, and I cannot figure out what triggered the new behavior. I tried restarting LibreOffice and my computer, but neither action cleared the problem.

Custom character style shortcut behavior

Could someone please suggest how to remedy this situation? I'm more interested in how to fix the problem than in why it occurred, though that bedevils me too.

edit retag flag offensive close merge delete

Comments

1

On my computer CTRL+ALT+L causes my screen to be locked. Why do I tell that? Keyboard shortcuts may be intercepted by the operating system (i.e. its desktop manager) and shortcuts defined there. Hence I'd assume that some changes in the operating system now cause some of your shortcuts being intercepted and instruct applications to select a certain character. To test this assumption - open any other application and type one of the three shortcuts now causing the special characters to appear. It that happens in other applications as well - it is not worth to search for a solution within LibreOffice, but to search within your operating system (which you did not mention).

Opaque gravatar imageOpaque ( 2020-12-24 11:43:23 +0200 )edit

Maybe you use Windows and have enabled the United States-international keyboard? It uses the Alt key to modify some keys

Earnest Al gravatar imageEarnest Al ( 2020-12-24 12:31:52 +0200 )edit