Ask Your Question
0

FIXED: Libre will not open (Windows 10x64, Libre 7.0.3.1)

asked 2021-01-07 20:35:43 +0200

brian@hamlinbank.com gravatar image

updated 2021-01-15 14:34:06 +0200

I have a PC running Windows 10. It will not fully load Libre. This has been an issue for the last several versions of Libre on this PC. I have several local users on this PC. Libre will open for some users but not all with the same permissions. I attempted directions found here: https://ask.libreoffice.org/en/questi...

Safe mode did launch. I completed the directions and upon relaunch Libre still will not fully load and remains unusable. I uninstalled the program, removed directories, ran a registry cleaner, rebooted, reinstalled, rebooted, and Libre will still not fully load.

Any ideas to try? Below is a screenshot of the permanent not loading status.

image description

edit retag flag offensive close merge delete

Comments

Earnest Al gravatar imageEarnest Al ( 2021-01-08 11:11:42 +0200 )edit

Originally, I had not. I reviewed it and feel I can provide more information. I received no install errors. I received no uninstall errors. Libre works perfectly for some users, for others, it continues to be unresponsive. Safe mode loads perfectly for all users but shouldn't be the final solution. Windows updates are current. I attempted to run the program with antivirus disabled to no avail. I have installed v7.0.3.1 with three different download packages just to avoid a corruption issue. I even downloaded them on three different PCs.

Thank you for the suggestion.

brian@hamlinbank.com gravatar imagebrian@hamlinbank.com ( 2021-01-08 16:55:41 +0200 )edit

Have you set LibreOffice as an allowed program in your anti virus, anti ransomware settings? For each login? Just turning off anti virus might still leave protection in place so if you are trying to open LibreOffice by double clicking a file and that file is protected then the whole process might fail.

Can you open LibreOffice from the menu?

Earnest Al gravatar imageEarnest Al ( 2021-01-09 00:24:16 +0200 )edit

Each user will have their own user folder which will need to be reset if it is not working on their log in to the OS.

Earnest Al gravatar imageEarnest Al ( 2021-01-12 11:17:23 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2021-01-13 02:28:02 +0200

hardik_gajjar gravatar image

Are you running X64 version of LO ? Uninstall X64 and try running X86 version. I had same issue with previous version of LO and got it rectified likewise. However, I could not know the reason behind it.

edit flag offensive delete link more

Comments

This actually worked!

brian@hamlinbank.com gravatar imagebrian@hamlinbank.com ( 2021-01-15 14:33:05 +0200 )edit
0

answered 2021-01-13 02:44:36 +0200

Earnest Al gravatar image

If Safe mode works for each user then you will have to reset the user profile for each user for which LO is not working correctly.

It might be best to backup user folder so close LO.

In File Explorer (Win+E), in the View tab, tick the box Hidden items.

Navigate to C:\Users\[username]\AppData\Roaming\LibreOffice\4 right-click and drag the folder user to a blank space just below and release, click the context menu Copy here and it will create a copy of the user folder in case things go sour. Leave folder open for now

Reopen LO in Safe mode and tick the box Restore from backup > Restore user configuration to the last known working state and press button Apply changes and Restart. If it all works the carry on with using LO like everybody else.

If not then try the button Reset to factory settings > Reset settings and user interface modifications. This should fix most issues. If not the Reset entire user profile will reset everything back to factory settings.

image description

If you did select the entire user profile option then all your autocorrect and templates will have gone. This is why we saved a copy. A new user folder will be created. Drag your data folders back into the new user folder: Autocorrect, Autotext, backup, template, wordbook.

Hope this helps. Cheers, Al

edit flag offensive delete link more

Comments

Thank you for the assistance! I followed the steps and got the same results as my above pic with LO not responding. One thing I found different was there was a .lock file in the APPData\LibreOffice\4 directory. I am not familiar with this .lock file. An important step I forgot about was your point of making all hidden files available.

brian@hamlinbank.com gravatar imagebrian@hamlinbank.com ( 2021-01-14 19:33:50 +0200 )edit

A .~lock. file can be deleted if you don't have LO document open. It should not be where you say it is as they are generated in the same directory as the open LO file to show that it is already open and to stop another user opening and modifying the same file.

I wonder if it is a permissions issue for the user folder?

Or is it an over-zealous setting in the anti-virus for some users? For Defender see next comment, for other AV it is likely to be a setting called anti-ransomware or something similar

Earnest Al gravatar imageEarnest Al ( 2021-01-14 20:16:59 +0200 )edit

Use the Windows Defender Security app to allow specific apps

  1. Open the Windows Security by selecting the shield icon in the task bar or searching the start menu for Defender.
  2. Select the Virus & threat protection tile (or the shield icon on the left menu bar) and then select Ransomware protection.
  3. Under the Controlled folder access section, select Allow an app through Controlled folder access
  4. Select Add an allowed app and follow the prompts to add apps
Earnest Al gravatar imageEarnest Al ( 2021-01-14 20:17:39 +0200 )edit
0

answered 2021-01-07 22:13:27 +0200

Rick_G gravatar image

Fist thing I would do is clean out all your temp files under APPDATA/:OCAL/TEMP and Windows/temp. If some will not delete, don't worry about it Then pick the module you are trying to looa and RUN AS ADMINISTRATOR and see if that does it. It it does load, you can close out and run normally after that

edit flag offensive delete link more

Comments

Thank you. I tried both cleaning out that directory and deleting the local PC user folder. The user folder was recreated when logging in the first time and still Libre does not respond when opening. (pictured in op).

brian@hamlinbank.com gravatar imagebrian@hamlinbank.com ( 2021-01-08 14:37:39 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-07 20:35:43 +0200

Seen: 84 times

Last updated: Jan 15