Ask Your Question
0

How can i get LibreOffice to automatically number pages?

asked 2021-01-10 06:35:39 +0100

Iceni gravatar image

updated 2021-01-10 08:31:06 +0100

ebot gravatar image

I have typed a short story and need to number pages. How? I have tried ALL day and part of rhe night and the instructions will not work for me. I am literally in tears. Thank you

EDIT_ebot yelling out

edit retag flag offensive close merge delete

Comments

  1. Read this tutorial and this tutorial.
  2. If you can’t find an answer, read these guidelines and ask a good question.
  3. Do not yell (and get a downvote for yelling).
gabix gravatar imagegabix ( 2021-01-10 08:07:20 +0100 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2021-01-10 08:13:49 +0100

ajlittoz gravatar image

Page numbers usually live in the header or footer. These "areas" are properties of the page style.

Considering the way your question is asked, I assume you're a newbie and have typed your short story without "fancy" formatting (all of it being done manually). The result of this is you have a single page style.

  • Format>Page Style to open the dialog to control the parameters
  • go to the Header tab (or the Footer if you prefer the page number at bottom of the page)
  • tick the Enable footer check box
  • OK

For convenience, I recommend you View>Text Boundaries and View>Formatting Marks so that you cann see how your page is structured. All the cues do not print, so that you can keep this hint always enabled.

Click in the top part of the page, above your text. This will put the cursor in the header.

  • Insert>Field>Page Number

After the field is inserted, you can format it with text before/after, tabs, ...

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

am a Newbie, I am a senior who just got a computer a few months ago, and I'm typing stories for my grandchildren, nothing fancy. I'm glad of any help. What I did many times was, go to. Format, then paragraph, then outline and numbering, then text flow. Breaks, page size, right page and started with 1 in the number. hit OK and I kept getting the same number on every page. I tried for 7 hours all told but could not get it to work. I must be missing something. I thank everybody for the suggestions which I will try again. I am unable to go to local computer classes because of restrictions.

Iceni gravatar imageIceni ( 2021-01-11 18:39:56 +0100 )edit

A good replacement for attending computer classes is reading the freely downloadable Writer Guide.

ajlittoz gravatar imageajlittoz ( 2021-01-11 18:59:37 +0100 )edit

"I kept getting the same number on every page."

Because you entered a constant number into the Footer/Header. Insert a FIELD named Page number. If it has a grey background color, then you are on a right way. (The grey color is appeared on the screen only, it will not be printed, it will not be appeared in a PDF export.)

Zizi64 gravatar imageZizi64 ( 2021-01-12 12:20:53 +0100 )edit
1

answered 2021-01-10 07:59:17 +0100

Zizi64 gravatar image

updated 2021-01-10 08:04:39 +0100

The AOO and the LO always number the pages. But the numbers are not displayed while you not adjust this property.

Switch on the Footer (or the header) in the applied Page Style, and insert the Page Field into the Footer. You can put the "/ Pages" too - if you need it...

The actual page number value will be appeared on every page what was formatted with same Page Style.

(And you can restart the numbering in an another part of the document if it is necessary. The absolute page number will not be changed, but the displayed value will be modified with a given offset value.)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2021-01-10 06:35:39 +0100

Seen: 73 times

Last updated: Jan 10