We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

How to prevent spacing before and after formulas in Writer?

asked 2021-01-12 20:46:37 +0200

Another User gravatar image

updated 2021-01-12 23:26:03 +0200

In Writer, in Styles - Frames - Formulas, I have wrap spacing set to 0.00". There's still a space before and after a formula. Lines starting with a formula appear slightly indented, and I can't type a character immediately before or after a formula without a gap.

It seems the wrap spacing is a space put before and after the box (frame?) containing the formula. This I had set to zero, and that decreased but didn't eliminate the spacing. There are spaces to the left and right of the formula, inside the box, unaffected by wrap spacing.

If I turn on a border, the border itself lines up properly at the start of a line, and the border immediately follows and precedes text without a gap. But the text of the formula itself has a space left as if to make room for a border, even when the border is turned off. Border padding is at 0.00"

Any ideas?

W10, v 7.0.3.1 x64

Thanks for any input. I can't be the only one struggling with this.

edit retag flag offensive close merge delete

Comments

If my answer below does not fix your problem, edit your question to explain in which style you set the wrap spacing.

Don't use an answer (this is a Question & Answer site, not a forum). Answers are reserved for solutions.

ajlittoz gravatar imageajlittoz ( 2021-01-12 20:57:23 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2021-01-12 20:56:09 +0200

ajlittoz gravatar image

updated 2021-01-13 11:26:48 +0200

Formulas are inserted as frames anchored As character. The frame style used to format the "object" is (surprisingly!) named Formula.

  • Click on the third icon in the style side pane toolbar to display the list of frame styles.

  • Right-click on Formula and Modify.

  • Go to the Wrap tab.

  • By default, spacing Left and Right are 0.2 cm. Change to your liking.

  • OK

All your formulas will be simultaneously adjusted.

EDIT 2021-01-13

The above recipe is valid for the outer spacing, the wrap space around the formula frame.

There is however another inner spacing defined by the formula itself. To change it, double-click on the formula to enter edit mode.

  • Format>Spacing
  • from Category, select Borders
  • you can now adjust the spacings around the formula; by default, you have 1 mm at left and right

Math is not based on mature styles like Writer. Consequently, you'll have to adjust every formula on its own. If you have more formulas to enter, you can record your settings pushing the Default button. Note this will be effective only on new formulas. Existing ones will not be modified.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more

Comments

Fixed! The new default can be saved in the template, and is permanent. Thank you enormously.

Another User gravatar imageAnother User ( 2021-01-14 02:06:01 +0200 )edit

Then click on the gray checkmark at left of answer to accept it. Click only once even if seemingly nothing happens. Thanks.

ajlittoz gravatar imageajlittoz ( 2021-01-14 07:52:58 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2021-01-12 20:46:37 +0200

Seen: 89 times

Last updated: Jan 13