Ask Your Question
0

Can't apply page style for footnotes [closed]

asked 2014-01-28 17:42:10 +0200

cptwunderlich gravatar image

updated 2016-02-19 04:00:10 +0200

Alex Kemp gravatar image

I'm using LibreOffice 3.5.7.2 on Ubuntu. I wanted to fix the footnotes on a large existing Document (created with OOo). Some of the footnote sections have thicker separator lines and different margins to the text.

I'm not sure what the difference between the page styles "Footnote" and "Default" are, since I entered the same settings on the "Footnote" tab (F11 -> Page Styles -> Right Click modify) [EDIT: OK, I found out. My Footnote Style doesn't include the Footer with the page field... So basically, I want to use the style Default - and I'd like it to be actually applied]

Applying these has some peculiar effects - that might be a bug. I select the footnote area on a page, double click on the page style and now sometimes the footnotes move to the next side (something seems to change in size). An example: I have Footnotes on page 1 and 3. On p3, the separator is thick and the margins different. I apply the other style (default vs. footnote) and some Footnotes from p1 jump to p2. p1 and p3 look fine, p2 now has a thick separator...

Different approach: I click into the footnote area, right click and select "Page" to format the page independently. It shows me the right settings, but the Text cleary doesn't follow (0.25mm bar, but I see a thick 0.5mm bar). I click OK nothing happens. I click "apply" and ... it updates the settings to "Space to text: -6mm", "Space to footer... -4.99mm". Yeah. Right...

Any Ideas on how I can my the applied style ACTUALLY apply?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 04:00:34.768082

1 Answer

Sort by » oldest newest most voted
1

answered 2014-01-28 19:12:59 +0200

Regina gravatar image

The wrong appearance of the separator line is likely the old bug https://issues.apache.org/ooo/show_bug.cgi?id=62249 . It is only wrong on screen and should be correct in print.

If you use different page styles, they might have different settings for margins, "register true", and positioning of the footnote area. Then it might happen, that a line which fits perfectly on the page in one page style has not enough place in the other page style and therefore goes to the next page.

After you have chosen another page style or altered a page style and nothing happens, you should try Tools > Update > Page Formatting.

If the distance between text line and separator line is different on different pages, you should look, whether the text lines are on the same vertical position. Without the feature "register true" it is likely, that the vertical position is different.

Keep in mind, that the appearance of the footnotes are determined in addition by the character style "Footnote Characters" and by the paragraph style "Footnote".

I see no other errors in footnote handling beside the mentioned bug.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-01-28 17:42:10 +0200

Seen: 621 times

Last updated: Jan 28 '14