Ask Your Question

Use writer field value in formula [closed]

asked 2014-02-04 19:13:47 +0100

JonnyTech gravatar image

I am trying to create an auto calculating template:
I insert a table into writer
Then I insert fields into some cells
I want to use the fields in a formula
But the value of the cell appears always zero
Example: =<A1>
How can field value be used in writer?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-28 21:56:37.919347


  • If cell A1 contains text, then the formula =<a1> results 0, because Writer formulas cannot handle text, see .
    • From your description it is not clear what you mean by "insert fields".
    • Do you have already tried to use references instead of formulas?
Regina gravatar imageRegina ( 2014-02-05 18:25:29 +0100 )edit

This was working perfectly in LO3. I know since I have an invoice template that uses the product of two fields to calculate the line total. It just suddenly stopped working, so this is a bug, not a lack a features.

I'd like to upload a little sample odt to explain the problem, but can't. I need karma. Whatever. Duh!

Here's a link to the file:

Lifeboy gravatar imageLifeboy ( 2014-07-09 16:45:58 +0100 )edit

An example document is always good. Now I see, what you mean. Please write a bug report and attach the document.

How do you have insert the input field? I cannot insert an input field via Insert > Fields, if it is not bound to a user field, but your document has no user field.

Regina gravatar imageRegina ( 2014-07-09 17:48:24 +0100 )edit

By the way, I'm using version: Build ID: 420m0(Build:2) on Ubuntu, just for completeness' sake.

Regina, I simple go Insert | Fields | Function Tab | Input Field and then add the name as the Reference. It seems the bug is that the name cannot be entered, the input box is greyed out. So, when I think about it, I'm not really naming the input field at all, I'm just added the reference.

Lifeboy gravatar imageLifeboy ( 2014-07-09 21:14:43 +0100 )edit

Lifeboy: "Function Tab" is the key, I have tried to use the Input Field from tab "Variables".

Regina gravatar imageRegina ( 2014-07-09 21:29:02 +0100 )edit

I filed a bug for this here:

Can anyone that uses a windows platform maybe confirm that this is similar and not just in the Linux version and confirm the bug please?

Lifeboy gravatar imageLifeboy ( 2014-07-09 22:04:17 +0100 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-07-09 17:52:39 +0100

Regina gravatar image

updated 2014-07-09 22:20:33 +0100

To work around this problem define a user variable, insert an input field for this user variable and then use the user variable in your formula.

Using the input field from tab "Functions" gives the error. Bug reports are and fdo#81126.

edit flag offensive delete link more


The bug you filed wat fixed on OpenOffice, but it's still in LibreOffice Build ID: 420m0(Build:3) on Ubuntu. How to do we bump this to the LO team?

Lifeboy gravatar imageLifeboy ( 2014-10-25 17:10:12 +0100 )edit

Question Tools

1 follower


Asked: 2014-02-04 19:13:47 +0100

Seen: 1,819 times

Last updated: Jul 09 '14