Ask Your Question
0

Aramaic White Square Characters [closed]

asked 2021-02-28 21:15:11 +0200

J. Stornoway gravatar image

updated 2021-05-17 15:44:55 +0200

Alex Kemp gravatar image

Note: This question was edited to changed the offensive term 'tofu' to 'white square.'

Sometime in the past 2 days my system lost the ability to properly render Aramaic in LibreOffice. Everything is fine in my other programs, my LO Writer is rendering 'white square,' and LO Calc is rendering 'white square' about half the time, and the proper characters the rest of the time.

I've used this system for ancient languages for years, and other than regular updates nothing has changed on the system. I've run some tests, and this is also affecting Phoenician, but not Hebrew, Arabic, or other RTL scripts.

Does anyone know what could be causing this?

Additionally, when I select the 'white square' in LO Writer, and go to Format->Character->Font, the proper character is rendered in the pop-up, meaning LO is internally recognizing the character, but not rendering it in the document. I assumed there was a problem with the settings in my document, however, older files that show the Aramaic text turn into a string of white square as soon as I try editing them.

And now for the strangest part, it does not affect double characters, meaning (AA) will render on screen, but not (A) or (AB), where A and B are substituted for the Aramaic letters.

System Info: Linux Mint 19.1 Cinnamon / Cinnamon Version 4.0.10 / LibreOffice Version: 5.3.11 / also confirmed the same problems on LibreOffice Version: 6.4.2.2

Also tested on the following with identical results: Pop!_OS 20.04 / KDE Plasma Version 5.18.5 / KDE Frameworks Version: 5.68.0 / Qt Version: 5.12.8 / LibreOffice Version 6.4.5.2

If anyone has experienced this before, I would appreciate any pointers on how I can resolve it without reinstalling my OS. I've read everything I could find in ask.libreoffice.org, and several other sites that seemed even vaguely related to the issue, but so far nothing seems relevant. Thanks in advance.

To the site admin, sorry the 'question' is not a 'question.' I'm not sure how to simplify this question. Feel free to change the 'question' to a 'question' if you can figure out what that question is.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-17 15:46:56.932450

Comments

Tofu is a Japanese dish produced of soybeans. How does it relate to Aramaic?

gabix gravatar imagegabix ( 2021-03-01 07:33:30 +0200 )edit

Wikipedia: Tofu, or tofu character, used as Internet slang for any of: glyph for undisplayable character (□), substitution character (�) or substitute character (␚). Sometimes incorrectly used for Mojibake (the garbled text).

@J. Stornoway: don't use slang! Most contributors are not English-language natives. I initially thought that "tofu" was the name of an Aramaic letter or diacritic.

Select your "tofu", press Alt+X. You get U+9999. Is it the correct hexadecimal encoding for the expected character? If so, is the correct font selected? By that I mean have you added some direct formatting which would override the font? Try to clear it on a selection with Ctrl+M.

ajlittoz gravatar imageajlittoz ( 2021-03-01 08:09:12 +0200 )edit

Even if we all here were native speakers of English, using slang is utterly stupid when discussing technical issues because slang words and expressions lack preciseness. Clear language is always better.

gabix gravatar imagegabix ( 2021-03-01 08:26:08 +0200 )edit

My apologies to everyone unfamiliar with the term tofu. I though it was the common term for the □ character. @ajlittoz: Yes, the correct hexadecimal encoding is showing, and I was using the same font I have used for years: Liberation Serif. Additionally, as I work in several languages, I have fonts for most languages installed. However, my system has stopped automatically switching to the default font it used to use: Lohit Devanagari, when I copy and paste a section of CTL text. Lohit Devanagari does not have the unicode range included, but would fail-over to another font that did. I haven't removed any fonts.

J. Stornoway gravatar imageJ. Stornoway ( 2021-03-01 08:27:33 +0200 )edit

Just thought I'd add that this appears to be related somehow to Java, as I got a Java error asking me to select my Java environment at Options=>Advanced. When I turned off Java, it sort-of started working again, but not as it was before.

Previously I have been using the font Liberation Serif, which is still not rendering the letters in question. After turning off Java (in Writer), I can now get the Noto Sans fonts for the Unicode ranges in question to render the text, but, I have to set the font manually for each section of text when I switch languages. The ranges are not being automatically detected and rendered by an appropriate font.

Does anyone know how to set (or reset) the default ranges for LibreOffice? I am still having no issues with other software rendering the characters, so I continue to suspect the issue ...(plus)

J. Stornoway gravatar imageJ. Stornoway ( 2021-03-01 08:28:09 +0200 )edit

Using a font is a personal choice. Writer will never interfere with your choice and change it based on criteria such as script block. Fonts are not required to cover the full Unicode rage (~1.1 M characters). The font renderer in the OS will eventually make a substitution when it detects that the font doesn't contain the needed character or use the "missing character" glyph otherwise.

You should use consistent paragraph and character styles. I fear from your description that you "direct format" your document, which is the most reliable way to make it next to impossible to format.

ajlittoz gravatar imageajlittoz ( 2021-03-01 08:28:38 +0200 )edit
  1. Show a sample file.
  2. Is Lohit Devanagari set for CTL text in the respective paragraph style properties.
gabix gravatar imagegabix ( 2021-03-01 08:30:24 +0200 )edit

The font renderer in LO changed between 5.3.1.1 and current 7.x. I don't remember at which version and this could be the cause of the problem if you don't style correctly your document.

ajlittoz gravatar imageajlittoz ( 2021-03-01 08:35:02 +0200 )edit

@gabix. Thank you for link to the Clear Language document, however, it does not clarify what the □ should be called on this particular website. I used the term I knew.

J. Stornoway gravatar imageJ. Stornoway ( 2021-03-01 08:36:03 +0200 )edit

It is called "officially" the missing character glyph in all articles related to fonts and in Unicode terminology.

ajlittoz gravatar imageajlittoz ( 2021-03-01 08:41:39 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2021-03-15 10:39:05 +0200

J. Stornoway gravatar image

Just thought I'd post what I think was the solution to the problem for anyone else that might encounter it. If it wasn't the actual solution, it resolved the problem either way.

After a few days of looking for issues with the OS (in my case Debian/Ubuntu/Linux Mint), and not finding anything that seems to be the cause, it occurred to me one of more fonts may have become corrupted and I reinstalled all the fonts I use. After a restart, the system is preforming like it was before.

Thanks to everyone that has contributed to old OpenOffice and LibreOffice over the years, and thanks to ajlittoz and gabix for offering suggestions on what the problem was.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2021-02-28 21:15:11 +0200

Seen: 61 times

Last updated: Mar 15