Ask Your Question
1

Base says my Oracle JRE v1.7 is defective. Is there a different one? [closed]

asked 2012-05-27 20:02:12 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I keep getting error messages regarding my java runtime environment. I've tried re-installing both java and libre office, but there is no change. The first error message reads:

Openoffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - OpenOffice.org - Java.

Then a second error message pops up:

The connection to the data source "New Database" could not be established. No Java installation could be found. Please check your installation.

When I go to Tools - Options - Java, there is my java - it says, "Oracle Corporation, version 1.7.0_04". Is there a different one?

Thanks! :)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-29 21:49:28.839898

8 Answers

Sort by » oldest newest most voted
0

answered 2012-08-19 08:08:49 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Rolling back to 1.6 build JRE is a work around, but JRE 1.7 builds are fully functional.

Must have a 32bit Java Runtime Environment, and correct environment/path to the JRE bin. Oracle JRE installers also place copies of JRE into the C:\Windows\sytem32 directory--which can cause a 64-bit JRE to be used rather than a 32-bit JRE.

If you have this problem, check the settings listed in javasettings_Windows_x86.xml in your per-user profile, e.g. C:\Users\<username>\AppData\Roaming\LibreOffice\3\user\config.

The .xml configurations must match the system JRE configuration. Problem for folks has been an .xml that lists 1.6 JRE while they have upgraded to a 1.7 JRE build.

Solution is to set PATH and JAVA_HOME variables, and delete the javasettings_Windows_x86.xml allowing it to rebuild with defaults resolved from system PATH variable. Removing the JRE copies from C:\Windows\system32 helps assure correct JRE as established by PATH is used.

edit flag offensive delete link more

Comments

I tried this - even followed the very detailed instructions published in related bugreport 50371 - but still getting the same error messages.... Win 7 Home, 64 bit... java is the 32 bit, etc etc.

Daniel D. gravatar imageDaniel D. ( 2014-01-04 00:34:32 +0200 )edit

Apparently you also need to point JAVA_HOME environment variable to your 32-bit JDK path. This is a stupid setup, why bother to have a setting in LibreOffice for Java runtime location if you had to change JAVA_HOME too?

jrao1 gravatar imagejrao1 ( 2014-05-05 06:42:00 +0200 )edit
1

answered 2012-06-21 20:30:54 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I found this problem occurs in Base in both OpenOffice and LibreOffice, which points to a Java problem. Uninstall 1.7.0 and install 1.6.0_33 . It worked for me!

edit flag offensive delete link more

Comments

Yes, and it worked for me too. Thanks.

DonLow gravatar imageDonLow ( 2012-08-14 03:21:53 +0200 )edit
0

answered 2012-08-23 17:43:42 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Well, vsfoote's answer is interesting, but also a bit of a faff! One shouldn't have to go through all that rigmarole. Wouldn't it be nice if JRE installed correctly when updating?

edit flag offensive delete link more

Comments

Yes, but it doesn't. So either correctly configure it yourself, or complain to Oracle to fix the JRE installers to establish an entry in PATH variable.

vsfoote gravatar imagevsfoote ( 2012-08-23 18:16:50 +0200 )edit
0

answered 2013-07-07 15:12:02 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

stumbled on a possible solution open a SPREAD SHEET go to tools-options-libra office-advanced-,wait 30 seconds it will load up java runtime enviroments instales-click on sun microsystem inc 1.6.0_22. worked for me.

hope this helps

edit flag offensive delete link more
0

answered 2013-10-11 18:38:28 +0200

Although the fix mitchj9 resolved this problem for me, if you're looking to find the indexes out there for all your tables, this HSQL statement is another way to find them.

SELECT * FROM "INFORMATION_SCHEMA"."SYSTEM_INDEXINFO"

edit flag offensive delete link more
0

answered 2012-08-19 11:16:24 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have seemingly the same problem on Os X 10.5, my JRE is 10.6_26 (Java HotSpot™ 64-Bit Server VM - build 20.1-b02-384, mixed mode), Base says I don't have any JVM, I tried getting rid of preferences, selecting the Java VM in preferences, restarting LO to no avail. Is there a workaround? Will it be fixed in 3.6.1?

BTW, I hoped the wizards for forms and reports had been fixed. Well, they didn't…

edit flag offensive delete link more
0

answered 2013-06-01 22:42:55 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I realize that LibreOffice is not really intended for people who function mostly in MS - there's some expectation that we will be somewhat "tech-savvy". However, I'm having the same (or similar) problem with Java and tried to follow the solution above. Went to "C:\Users\<username>\AppData\Roaming\LibreOffice\3\user\config." (as amended for my files) and found a file (javasettings_windows_X86) which opened in Notepad with a dire long warning ("Don't mess with me!" more or less). Somewhere down that long line of incomprehensible text was this exquisite tidbit: "file:///C:/Program%20Files%20(x86)/Java/jre6</location> <version>1.6.0_35"

I assume that this means I have Java6 installed. However, my reaction to all this was neatly paraphrased earlier in the same line by ""UTF-8"?" which I'm inclined to rewrite as ""WTF-infinite"?"

Ok, I'm old and out of date - I accept that - but it would really help me (and perhaps some others) if there were somewhere to find detailed, step by step fixes for (sort of) common issues. Especially when the problem is in the user's setup, not in LibreOffice.

I'm a fan of Open Source software - I also greatly respect you who take the time to do all this. And I would love to see the School Board I work for switch from MS to LibreOffice... That might well lead to 20,000 students realizing that they don't have to buy everything from the big guys. (About 10 years ago I set up a Linux network of 6 PCs because there was no budget for MS. Worked too (to my shock and amazement) and a number of students were suitably impressed. And turned on to the idea of open source.

But one thing MS does exceptionally well is write tutorials that walk you through click by click. And that's what I need for this situation. Anybody out there really bored by the spring so far?

Many thanks for reading this rant (assuming you did) and TIA for any help you can give.

Roger.

edit flag offensive delete link more
0

answered 2014-04-05 05:49:09 +0200

I can't suggest installing Java 1.6. It had some well publicized security issues. Oracle stopped supporting it in early 2013, so if any more security issues in 1.6 have been found or will be found, they won't be fixed. Oracle urges Java users to install the most recent version of Java 1.7 or Java 1.8.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-05-27 20:02:12 +0200

Seen: 22,652 times

Last updated: Jul 17 '14