Ask Your Question
0

Frequent disconnects from remote database [closed]

asked 2012-05-28 17:43:10 +0200

RichA gravatar image

updated 2015-10-16 04:06:04 +0200

Alex Kemp gravatar image

I am using Base to connect to a remote MySQL database.

When I set up the original connection I specified "Connect to an existing database" of type "MySQL"

On the next screen I chose "Connect using JDBC" On the next screen I specified MySQL driver class "com.mysql.jdbc.Driver" (I tested the class and it loads successfully, although I did notice another time that I was able to connect successfully even when the class did not load successfully.)

Whenever I am working with this database it will disconnect if I fail to communicate with the database for a couple of minutes (or so).

As long as I keep performing DB operations I stay connected. If I pause I lose the connection.

At that point I know of no way to reconnect except by exiting from Base and restarting it. IS THERE A WAY TO RECONNECT WITHIN BASE?

Since this is a JDBC connection, is there some Java parameter I need to set?

I notice that when I go to Tools > Options > LibreOffice > Java > Parameters there is a place to add a parameter. SHOULD I ADD SOME PARAMETER HERE?

I notice that when I go to Tools > Options > LibreOffice Base > Connections, the driver com.mysql.jdbc.Driver is NOT listed among the drivers known to LibreOffice. Should it be? Are any of the drivers listed relevant to me then? Am I really using one of the listed drivers and not com.mysql.jdbc.Driver.

Any answers--or clarification of something I seem confused about--would be appreciated.

I have tried this under Ubuntu 11.04, and also Windows 7.

Thanks very much.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 04:06:38.014042

1 Answer

Sort by » oldest newest most voted
1

answered 2012-05-28 21:14:18 +0200

RichA gravatar image

Apparently what is needed is to add "?autoReconnect=true" (without the quotes) immediately after the name of the database (no intervening space).

I did this and no more disconnects.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-05-28 17:43:10 +0200

Seen: 924 times

Last updated: May 28 '12