We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

how do I change the default page size from letter to A4 [closed]

asked 2021-03-29 16:55:27 +0200

rew gravatar image

updated 2021-05-16 17:03:29 +0200

Alex Kemp gravatar image

I followed the directions in: https://ask.libreoffice.org/en/questi...

and... still I get "letter" as the default page size when I try to print a new document.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-05-16 17:05:07.504797

Comments

See also this FAQ.

Mike Kaganski gravatar imageMike Kaganski ( 2021-03-29 18:00:58 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2021-04-01 13:38:20 +0200

rew gravatar image

Because I know I'll run into this a couple of years from now, and I'm hoping google will point me here when I try to solve it that time. ("I'll remember: "I know I had a lot of trouble last time figuring it out, but in the end the solution was simple... but what the H* was the solution?").

  • open libreoffice,
  • create a new wirter document.
  • for good measure go to format -> page Style and set the page format to A4.
  • then go to file->printer settings-> <your printer=""> and set the page size to what you need.
  • then use file->templates->save as template, click "set as default" before saving.

If at some point in the future this doesn't solve it in one go, one of the previous steps that were performed was also necessary: read the other answers.

edit flag offensive delete link more
0

answered 2021-04-01 10:38:05 +0200

If you create a file from the right click menu, then you need to update the Windows file used for that context menu. See last post of this tutorial: https://forum.openoffice.org/en/forum....

edit flag offensive delete link more

Comments

... which has changed starting from 7.1 (see tdf#133661).

Mike Kaganski gravatar imageMike Kaganski ( 2021-04-01 10:47:54 +0200 )edit

I've never seriously used windows. I dropped DOS when migrating to a bigger hard drive I noticed I had NEVER booted the DOS partition I was about to migrate since the previous time I HAD copied the old dos partition. Same happened with my current laptop. I kept the windows partition when installing Linux thinking I'd be able to check it out... When migrating to a bigger SSD: I had not once done that.

Sooo. back to the problem. When I do "create new writer document" from the libreoffice control panel... Does it use a template? The post you pointed me to explains that I can create a template, but to make it the default template I'd have to save it with a specific name, like "default"?

rew gravatar imagerew ( 2021-04-01 11:31:23 +0200 )edit

Ah, OS information in the question would have helped then. The main point is that your template with your custom settings has to be declared as a template (wherever it is located). It has not to have a specific name. It has just to be "set as the default" one. And yes, LO will use the default template for each new document.

Hagar Delest gravatar imageHagar Delest ( 2021-04-01 11:42:44 +0200 )edit

For the record: I appreciate libreoffice trying to find a reasonable default using several methods for something that hasn't been configured. But changing such a default should be much easier than all the hoops I've been through.

rew gravatar imagerew ( 2021-04-01 11:59:35 +0200 )edit

Has you managed to do it in the end?

In this case, thanks to confirm with the button left of the best answer and to upvote it (^) so that other users can spot the question as a relevant one if they have the same issue.

Hagar Delest gravatar imageHagar Delest ( 2021-04-01 13:25:55 +0200 )edit

OK. I went ahead, opened up a new document, went to format->Page style to set the page to A4. Lo and behold it already was. I then did file->templates->save as template, called it "mydefault", enabled "set as default" and hit save. I then closed libreoffice, created a new document and went to print: still letter.

OK. I solved it.... The "printer settings" are ALSO saved with the template. So create blank document, go to file->printer settings, change them as required, then save template as default, then you're set.

rew gravatar imagerew ( 2021-04-01 13:32:13 +0200 )edit

I've created a separate "answer" with concise info on how to do it that worked for me. I thought of upvoting that but expected that the system would not allow it. So I didn't even try. In response to your direct question I tried and indeed it doesn't allow me to upvote my own answer.

In the end your suggestion: "look at templates" pointed me in the right direction, but it didn't prove to be the full solution.

rew gravatar imagerew ( 2021-04-01 14:00:50 +0200 )edit

Personally, I always disable the feature: Options > Load/Save > General and in the Load section, uncheck the Load printer settings with the document.

I don't really see the point of this feature. Especially if in a couple of years you've changed your printer. You would have to change your template and then each document made based on it would ask for the update when you open them.

Hagar Delest gravatar imageHagar Delest ( 2021-04-01 15:54:56 +0200 )edit
0

answered 2021-03-29 17:38:23 +0200

Opaque gravatar image

Hello,

from my perspective the answer given in the link provided in your question should work with one addition before step 3.

2a) Go to File -> Printer Settings -> Button: Properties -> Tab: Paper and set Paper Size to A4 as well (for your default printer)

At least that does it on my GNU/Linux System openSUSE Leap 15.2 KDE/Plasma Framework and using LibreOffice

Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
edit flag offensive delete link more

Comments

I did the file ->printer settings instruction a couple of times: No go. I did the suggestion from the FAQ (change from DEFAULT-english to just "english" in the language settings and THEN did the printer settings instruction again... No go. I then went back to tools->options-> language and changed a third "Default-English" into just plain "english (US)" I then went back and set the file->printersettings->myprinter->properties to A4 again, quit libreoffice and restart and.... Nothing back to "letter".

rew gravatar imagerew ( 2021-03-29 18:54:08 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2021-03-29 16:55:27 +0200

Seen: 64 times

Last updated: Apr 01