Ask Your Question
2

Master slides, and title/subtitle properties? [closed]

asked 2014-03-03 18:40:11 +0200

sdaau gravatar image

updated 2015-09-11 21:48:26 +0200

Alex Kemp gravatar image

I have made a very simple start of a slide in PowerPoint 2010 - put in blue background, opened Slide Master, and therein changed the default font settings to Arial, bold, white. When I exit the PowerPoint slide master, PowerPoint shows the slide like this:

test-odp-pp.png

Then, I export from PowerPoint as .odp, and I load that into LibreOffice Impress 4.2.1.1. First problem is that the title and subtitle aren't white, as I set them to be, but black:

test-odp-lo1.png

... and furthermore, it says "Click to add Text" where I expect "Click to add subtitle".

Interestingly, if I open the Slide Master in LibreOffice, I get this (have no idea why the image doesn't show, try clicking on it):

test-odp-lo2.png

... that is, _here_ the font settings are, for some reason, shown as expected (Arial, white, bold)? Note that if I click inside the Title field, character properties shown are Arial, 24, white, bold (there is a tiny, tiny outline indicating it around the A); and in the bottom left corner, it says "TextEdit: Paragraph 1 ...."

So now, if I select the subtitle frame, I get this:

test-odp-lo3.png

... that is, the character properties are Liberation Sans, 32, auto font color (resolving to black), and not bold. Also, on the bottom left corner, it says: "Text Frame: 'Click to ...' 'Subtitle 2' selected." I note this, because when the title text frame is selected, it says instead: "Title Text: 'Click to ...' 'Title 1' selected."

So my questions are:

  • Can I get the subtitle message to be "Click to add subtitle" instead of "Click to add Text"?

My guess is, that "Click to add Title" is generated because the title frame is of type "Title Text" ; however, since the subtitle frame is of type "Text Frame", we get just "Click to add Text" for it. In Navigator, I can see "Title 1" and "Subtitle 2" child nodes to "Slide1"; and in Styles and Formatting, I can see "Title" and "Subtitle" styles defined - but I cannot find a way to apply a style from "Styles and Formatting" to an object in "Navigator". So in other words:

  • Can I somehow set the type/class of the intended subtitle frame to be "Subtitle Text"? How?

And finally:

  • How can I format the text frames, so the same font style rendering is shown in _both_ master slide view _and_ normal view?

Here I would have liked to upload ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 17:12:26.595444

3 Answers

Sort by » oldest newest most voted
1

answered 2014-03-04 06:04:16 +0200

Regina gravatar image

updated 2014-03-04 06:59:55 +0200

You need not use the master page to set font properties, but you can use the Style&Formatting dialog (F11) as well. You find "Subtitle" in the right category, which is "Presentation Styles".

I cannot reproduce the problem with a new presentation. It seems to be a special problem with the kind of .odp which PowerPoint produces.

You can try to get better results, when saving in PowerPoint in ppt (or pptx) and let LibreOffice convert it to .odp format on import.

edit flag offensive delete link more

Comments

Many thanks for that, @Regina ! One of the things I failed to understand, is that if you select an object (e.g. a text frame), and have "Style & Formatting" open; the "style" that the object has should be automatically highlighted as a node in the "Style & ..." tree! I think, I tried to change the font settings of the Subtitle style, and finally it got shown outside of master view - unfortunately, this doesn't make the text frame a "Subtitle Text" type of object... Cheers!

sdaau gravatar imagesdaau ( 2014-03-04 12:46:38 +0200 )edit
1

answered 2014-03-04 10:21:53 +0200

David gravatar image

updated 2014-03-04 10:26:50 +0200

Very well documented question - thanks for that!

I just tried to replicate the steps in the question, and got very much the same result:

  1. Using Powerpoint 2010 (in Win7): created a new presentation with gradient background, and custom font choice in the slide master.
  2. Saved as PPTX.
  3. Opened PPTX in LibO Impress 4.2.1.1
  4. Result: terrible: gradient changed (not single top-to-bottom, but "middle" dark, light top/bottom); wrong fonts, sizes, colours, etc. What a mess.

So -- I went back to Powerpoint, and saved the same file now as a .PPT ("PowerPoint 97-2003 Presentation"), and opened it in Impress:

  1. Perfect.

So the workaround, for the moment anyway, is to save as PPT and avoid PPTX. (I have had similar experience of DOC being handled better in LibO than DOCX.)

[P.s. The LibO part of this answer was carried out in Ubuntu 13.10 (Saucy Salamander); I have Win7 with Office 2010 running in VirtualBox. FWIW.]

edit flag offensive delete link more

Comments

Many thanks for that, @David - I first tried importing a .pptx into LO, and when I realized there was a formatting problem, I tried the "export .odp from PP" route... so save as .ppt is a nice tip! I think the problem is what determines the shown style: the style of the text frame, or its contents? But as noted in the comment to @Regina, changing "Subtitle" style worked. Cheers!

sdaau gravatar imagesdaau ( 2014-03-04 12:54:12 +0200 )edit
1

answered 2014-03-04 01:05:53 +0200

ROSt52 gravatar image

@sdaau - I think you found a bug. As you have already a pretty good description of the bug, may I ask you to file a bug report at: https://www.libreoffice.org/get-help/bug/

edit flag offensive delete link more

Comments

1
Regina gravatar imageRegina ( 2014-03-04 07:10:00 +0200 )edit
1

@Regina - Thanks for writing the bug report!!!

ROSt52 gravatar imageROSt52 ( 2014-03-04 10:43:40 +0200 )edit

Many thanks, @Regina - I'm not sure I have an account at freedesktop, and opening an account and waiting for confirmation etc, would have taken me a bit too much time these days (they should also start something with openID :) ); so the submitted bug is much appreciated! Cheers!

sdaau gravatar imagesdaau ( 2014-03-04 12:25:52 +0200 )edit

@sdaau - You can write bug reports with your normal AskLibO login. Maybe you click short the link and have a look at what pops up.

ROSt52 gravatar imageROSt52 ( 2014-03-04 13:53:43 +0200 )edit

Fantastic, @ROSt52 - had no idea about that; that is certainly a feature I like a lot; and will try to make use of it in the future... Cheers!

sdaau gravatar imagesdaau ( 2014-03-09 13:37:38 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-03-03 18:40:11 +0200

Seen: 10,046 times

Last updated: Mar 04 '14