Ask Your Question
0

in base - table create (design view) - I cannot save a table. I am just using the design view screen, not coding create statements, of course. Nothing found in help [closed]

asked 2014-04-05 00:24:01 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Base LO ver 4.2.2.1 This is the diagnostic info from clicking "more":

SQL status 37000 error code: -11

text of the message:

Unexpected token in statement [CREATE TABLE "Table1" ("Chart Number" INTEGER NOT NULL IDENTITY,"body name" VARCHAR(100) NOT NULL,"body abbr" VARCHAR(100),"Longitude" NUMERIC(15,10),"Latitude" NUMERIC(15,10),"Right Ascension" DECIMAL(15,9),"Declination" DECIMAL(15,9),"Azimuth" DECIMAL(15,9),"Altitude" DECIMAL(15,9),"daily travel" DECIMAL(15,9),"Direct/Retro" CHAR(1,]

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 19:01:37.342825

1 Answer

Sort by » oldest newest most voted
0

answered 2014-04-05 08:01:06 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Okay - I deleted lines and re-entered field defs after I noticed that the generated create command ended with the "char(1," designation - there were more fields after that which were apparently not recognized. I had been playing with copying and pasting the lines in the design view GUI table def screen. I suspect this is a bug. I got by it with retyping and not defining a field as 1 char (? !). Will report as a bug.

edit flag offensive delete link more

Comments

Still having a problem with this error. No chance in saving table (even a simple one, without formating).

Werewolf gravatar imageWerewolf ( 2017-11-26 09:49:49 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-05 00:24:01 +0100

Seen: 541 times

Last updated: Apr 05 '14