Ask Your Question
0

Is there an UK English dictionary which does not also include US English spelling? [closed]

asked 2014-04-14 12:57:40 +0200

Baz P gravatar image

updated 2015-09-08 08:51:34 +0200

Alex Kemp gravatar image

I cannot get a UK English spellchecker which does not also include US English spelling. This was not a problem with LibreOffice 3 as the standard English UK spellchecker worked perfectly but this is not the case with LibreOffice 4.

Is it possible to replace the dictionary in LibreOffice 4 with the one in LibreOffice 3? If so, where is the spellchecker dictionary located in LibreOffice 3 (using Ubuntu [Zorin 5]) so I can, perhaps, copy it or could you make it available on line so that I can download it?

I'm now using Mint 15 and the and LibreOffice Version: 4.1.5.3, Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Simple examples: neighbor; labor, center, color are not picked up as incorrect although, of course, they are incorrect in a UK English dictionary.

Thank you in anticipation of your attention.

Baz

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-21 07:08:26.693527

1 Answer

Sort by » oldest newest most voted
0

answered 2014-04-16 09:40:52 +0200

oweng gravatar image

updated 2014-04-20 03:37:59 +0200

It sounds as though either the en-GB language pack is not installed or the text in the document is not set to be en-GB. EDIT: Please refer the checklist provided in this answer.

There is certainly no problem with the en_GB or en_US dictionaries as a quick grep verifies:

$ grep -e labor /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic 
collaborate/6   1
collaboration/2 1
collaborationist/2  1
collaborative/42    1
collaborator/2  1
elaborate/88    1
elaboration/2   1
elaborative 1
elaborators
laboratory/13   1
laborious/14    1
$ grep -e labor /opt/libreoffice4.1/share/extensions/dict-en/en_US.dic 
antilabor
belabor/11  1
collaborate/6   1
collaboration/1 1
collaborationist    1
collaborative/8 1
collaborator/1  1
elaborate/67    1
elaboration/1   1
labor/23    1
laboratory/15   1
labored 1
laborer/1   1
laboring    1
laborious/16    1
laborsaving
$ grep -e color /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic 
coloration/2    1
coloratura/2    1
colorimeter/2   1
colorimetric
colorimetry 1
$ grep -e color /opt/libreoffice4.1/share/extensions/dict-en/en_US.dic 
color/23    1
colorant/1  1
coloration/2    1
coloratura/1    1
colorblind
colorblindness/3
colored/1   1
colorfast/33    1
colorful/16 1
colorimetric
coloring/1  1
colorist/10 1
colorization/2  1
colorize/6  1
colorless/16    1
color   1
colorway/10 1
decolorizing
discolor/11 1
discoloration/1 1
multicolored
multicolor  1
recolor/11  1
technicolor 1
Technicolor 1
tricolor/1  1
uncolored   1
varicolored
watercolor/18   1
watercolorists
edit flag offensive delete link more

Comments

Thanks very much for your help but now I may need your further assistance as I'm not the most adept computer expert. My grep is the same as yours and the en-gb.dic is fine when I look at its various spellings. In my language options I have default language English-UK so can't have loaded the language pack correctly. Further advice would be most welcome - particularly how to rectify my incompetence!

Baz P gravatar imageBaz P ( 2014-04-16 16:03:17 +0200 )edit

For Mint (.deb package), v4.1.5.3, x86_64 architecture, you will need to download the en_GB language pack, unzip it, and install it ($ sudo dpkg -i *.deb). The x86 version is here.

oweng gravatar imageoweng ( 2014-04-17 09:46:59 +0200 )edit

Still not working OK. The En-GB dictionary is located in my file system at /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic but no matter what I click in LibreOffice Tools Options Languages or Writing Aids I can't get it to function. As a matter of interest under "Default Languages for Documents" I have ABCtick Default English (UK) but loads of other languages with ABCtick beside them. Could deleting all the others en-??.dic from /opt/libreoffice4.1/share/extensions/dict-en/ be the cure?

Baz P gravatar imageBaz P ( 2014-04-18 13:11:40 +0200 )edit

FWIW - I'm on Mint (13 LTS) but LibO 4.2.3.3: it's working fine for me. Here's a screenshot of my language options for comparison. I also have other languages (which I have "installed") as possible "Default languages for documents", but the main default is "English (UK)". When you do your spell check (F7), what language is showing at the top of the dialog that opens? and which "Text language" in the drop-down at its top?

David gravatar imageDavid ( 2014-04-18 15:40:40 +0200 )edit

Thanks for your help David and oweng.

David, My Option - Language Settings-Language is identical to yours apart from the fact I do not have Hebrew and my date preference is DMY. When I press F7 I get "Spelling and Grammar: English (UK) and the text language in the drop down at the top is English (UK)!! I'm mystified. Should I just update to the latest version and hope for the best?

Baz P gravatar imageBaz P ( 2014-04-19 16:03:23 +0200 )edit
1

What does it state in the status bar for the document in question? I presume the "English (UK)" entry in the languages selection has the blue tick next to it? If this is all as expected, then I am unclear why the spell-checker is not working as expected. Perhaps try a user profile reset and if that is unsuccessful, try un/re-installing.

oweng gravatar imageoweng ( 2014-04-20 02:12:22 +0200 )edit

Thanks again oweng,

Status bar shows English (UK). When I open "Option - Language Settings-Language-Default languages for documents" all English language options have a blue tick next to them as do all French and Spanish for some reason. The only difference is that it starts with "Default - English (UK)". I might have a go at installing the latest version - would it be wisest to delete the existing one first?

Baz P gravatar imageBaz P ( 2014-04-21 20:12:26 +0200 )edit

@Baz P, I always delete a prior install. Migration of user-profile detail has been known to cause problems in the past. Be sure however to backup anything in your user profile that you want to keep (e.g., user-defined dictionaries).

oweng gravatar imageoweng ( 2014-04-22 02:32:20 +0200 )edit

I must be a complete dunderhead as I can't get a dictionary working that doesn't permit EN-US words...it's like a plot!! Today I've not only reloaded LibreOffice in the hope that my problem would resolve itself (Version 4.0.2.2 (Build ID: 400m0(Build:2) but I've also reinstalled Mint, just in case. I must be either doing something wrong or not doing something I should be doing. I'm so mixed up now I don't even know where to get a UK-EN Dictionary let alone load it.

Baz P gravatar imageBaz P ( 2014-04-22 22:40:39 +0200 )edit

@Baz P, "Build ID: 400m0(Build:2)" this indicates you are using the Mint-supplied variant of LO from the Mint repositories. Perhaps try installing the website version as a test. This should at least indicate if it is a problem with the Mint-supplied variant.

oweng gravatar imageoweng ( 2014-04-30 15:00:06 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-14 12:57:40 +0200

Seen: 1,923 times

Last updated: Apr 20 '14