Ask Your Question
0

Linux access to Windows server no lock files [closed]

asked 2014-04-17 13:15:41 +0100

jheath gravatar image

updated 2015-08-28 14:00:13 +0100

Alex Kemp gravatar image

My LibreOffice woes continue regarding access to a Windows 2012 server (via DFS) from Linux Mint 16. In addition to the problems appending to a text file on the server ( http://ask.libreoffice.org/en/questio... ), now we are noting that sometimes a Calc document will be opened from a Linux machine and it will not create a .~lock. file, so another user can open the file thinking he has exclusive access and make changes, save and quit, but those changes will be lost if the original user then saves his changes. We are using the default Samba settings, and accessing the server through smb://myserver.org/server. Is the problem with Samba? LO? Is there another way to access our Windows server that I could try other than Samba?

Maybe this is beyond the scope of this forum, but if anyone has some pointers or suggestions, I would be very appreciative.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-22 16:46:23.118273

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-14 10:43:49 +0100

jheath gravatar image

We found a work-around to this problem in the answer from oweng found here:

http://ask.libreoffice.org/en/question/23021/solved-open-ods-or-odt-files-from-a-smb-share-throws-damaged-file-error/?answer=23048#post-id-23048

Specifically the code line that starts with "sed", but we found we needed to prefix it with a "sudo", like this:

sudo sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-*

So it appears to be some sort of LO optimization that needs to be turned off to avoid this bad behavior.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-04-17 13:15:41 +0100

Seen: 505 times

Last updated: May 14 '14