Ask Your Question
0

How to stop Calc formating cells? [closed]

asked 2014-05-22 09:32:29 +0200

arnoldpredator gravatar image

Hi,

I am typing data on Calc and I have these numbers 1,220 ; 223 ; 223,3

Well, I am not able to type that at Calc.

If I type 1,220 it automatically deletes the last zero, which is not what I want.

To solve that problem I go to Format, Cells, Numbers and I choose 3 decimals.

Well, in that case it appears another problem, when I type 223 it shows 223.000

So, Is there any way to just type 1,220 or 1,100 AND 245 at the same time without deleting or adding zeros?

I mean if the format are numbers, I know I could simply choose text, but that is not what I want.

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-23 12:05:07.491593

3 Answers

Sort by » oldest newest most voted
0

answered 2014-05-22 21:13:06 +0200

m.a.riosv gravatar image

There is no way to retain zeroes without value in decimals positions, except you enter the numbers as text not as numbers, with a single quote before the number or formatting the cells as text @.

But doing so, only direct references interpreting it as numbers, e.g.: A1: '1 B1: =A1*2 = 2 B2:=SUM(A1) = 0

Explaining a bit the context for that need, maybe someone can give a solution or a workaround.

edit flag offensive delete link more
0

answered 2014-05-22 23:36:31 +0200

arnoldpredator gravatar image

Thanks for your replies.

I am working for a guy who needs it to be typed into Excel, I just wanted to type it as similarly as the jpeg that he sent me to work with.

edit flag offensive delete link more
0

answered 2014-05-22 10:46:59 +0200

ROSt52 gravatar image

It seems the problem is the regional setting for the decimal "symbol" in your OS and in LibO Tools > options > languages > decimal separator key and the your local setting on the same tab.

If you want to use the " , " as a decimal symbol you need to consistently set it up in your OS and in LibO. Typically language settings are used to "automatically" set it all up.

Next you need to format your cells. Right click on a cell and look for the format you need. It is possible (99% sure) to suppress zeros after the decimal point but I don't know the right settings by heart. Play around and you will find it.

My personal dream is that I can set up in the options of LibO the number format independently of OS settings and languages. In an international environment I made the experience that only a "space" as the thousand separator and a " . " as the decimal sign is understood.

edit flag offensive delete link more

Comments

Hi @ROSt52, it's possible set up the styles for an specific language, so I think your dream came true.

m.a.riosv gravatar imagem.a.riosv ( 2014-05-22 21:17:40 +0200 )edit

@mariosv - I checked again tools > options > languages. I can select there setting for Local Settings by country even if my user interface is a different languages. This is good. But my dream is to set up number and date formates independent on user interfaces and languages. Should this be possible please let me know.... ...and you become my very best friend. For the next ~ 6 month I will remain on XP and then move to Linux.

ROSt52 gravatar imageROSt52 ( 2014-05-25 08:21:06 +0200 )edit

@ROSt52, set up the cell style for an specific language: [Ctrl+1] or editing an style, select Numbers tab, Language option.

m.a.riosv gravatar imagem.a.riosv ( 2014-05-25 11:57:59 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-05-22 09:32:29 +0200

Seen: 123 times

Last updated: May 22 '14